summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-05-28 18:09:09 -0400
committerSolomon Choina2018-05-28 18:09:09 -0400
commit3b3f3a3032d2055eca9a27ada51439368c40c114 (patch)
tree8af2ef8c8102dd34f4c379f46854527d3138c4b2
parent888c351f5c33a6e47abc8cc4c9c1161d3b05a731 (diff)
downloadaur-3b3f3a3032d2055eca9a27ada51439368c40c114.tar.gz
last depends
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 5 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c524fe3bd09..225d14c7286d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,8 +16,10 @@ pkgbase = way-cooler-git
makedepends = libxcursor
makedepends = cairo
makedepends = gdk-pixbuf2
- depends = wlroots-git
- depends = rust
+ depends = lua
+ depends = gdk-pixbuf2
+ depends = cairo
+ depends = wlc
optdepends = weston: default terminal emulator
optdepends = dmenu: default launcher
optdepends = way-cooler-bg: draws a background for Way Cooler
@@ -25,12 +27,8 @@ pkgbase = way-cooler-git
conflicts = way-cooler
backup = etc/way-cooler/rc.lua
source = way-cooler-git::git+https://github.com/Immington-Industries/way-cooler.git
- source = git+https://github.com/swaywm/wlroots-rs
- source = git+https://github.com/swaywm/wlroots
source = 0001-wlroots-needs-to-be-dynamic.patch
md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
md5sums = 0aa8ef19bbe4d66d5dd6d796498ab8e2
pkgname = way-cooler-git
diff --git a/PKGBUILD b/PKGBUILD
index 55f7bae32855..6979b34d171d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Customizeable Wayland compositor written in Rust"
arch=('i686' 'x86_64')
url="https://github.com/Immington-Industries/way-cooler"
license=('MIT')
-depends=('wlroots-git' 'rust')
+depends=('lua' 'gdk-pixbuf2' 'cairo' 'wlc')
makedepends=('python' 'cargo' 'rust' 'git' 'wayland-protocols' 'clang' 'libxcursor'
'cairo' 'gdk-pixbuf2')
optdepends=('weston: default terminal emulator'
@@ -17,12 +17,8 @@ provides=('way-cooler')
conflicts=('way-cooler')
backup=('etc/way-cooler/rc.lua')
source=("${pkgname}::git+https://github.com/Immington-Industries/way-cooler.git"
- "git+https://github.com/swaywm/wlroots-rs"
- "git+https://github.com/swaywm/wlroots"
"0001-wlroots-needs-to-be-dynamic.patch")
md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
'0aa8ef19bbe4d66d5dd6d796498ab8e2')
pkgver() {
@@ -33,15 +29,6 @@ pkgver() {
prepare() {
cd $pkgname
git submodule update --init --recursive
- #git submodule init wlroots-rs
- #git config submodule.wlroots-rs.url ../wlroots-rs
- #git submodule update --remote --init wlroots-rs
- #cd ../wlroots-rs
- #git submodule init wlroots-sys/wlroots
- # git config submodule.wlroots.url ../wlroots
- # git submodule update --init --recursive --remote wlroots-sys/wlroots/
- # cd ../wlroots
- # git reset --hard 79683ee497cff4e363612933af2f068cfea9b19c
}
build() {
cd "$srcdir/$pkgname/wlroots-rs"