summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-05-28 17:40:59 -0400
committerSolomon Choina2018-05-28 17:40:59 -0400
commit888c351f5c33a6e47abc8cc4c9c1161d3b05a731 (patch)
treef563ef4583942a0a19a5d2151806f03ddf9abcd7
parent9de7e15773a6393e3f4c09e08f5002ae9b68e7e1 (diff)
downloadaur-888c351f5c33a6e47abc8cc4c9c1161d3b05a731.tar.gz
this finally builds
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76283cfd73bb..9c524fe3bd09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,12 +7,15 @@ pkgbase = way-cooler-git
arch = i686
arch = x86_64
license = MIT
+ makedepends = python
makedepends = cargo
makedepends = rust
makedepends = git
makedepends = wayland-protocols
makedepends = clang
makedepends = libxcursor
+ makedepends = cairo
+ makedepends = gdk-pixbuf2
depends = wlroots-git
depends = rust
optdepends = weston: default terminal emulator
diff --git a/PKGBUILD b/PKGBUILD
index bb8d0a04f6dc..55f7bae32855 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@ arch=('i686' 'x86_64')
url="https://github.com/Immington-Industries/way-cooler"
license=('MIT')
depends=('wlroots-git' 'rust')
-makedepends=('cargo' 'rust' 'git' 'wayland-protocols' 'clang' 'libxcursor')
+makedepends=('python' 'cargo' 'rust' 'git' 'wayland-protocols' 'clang' 'libxcursor'
+ 'cairo' 'gdk-pixbuf2')
optdepends=('weston: default terminal emulator'
'dmenu: default launcher'
'way-cooler-bg: draws a background for Way Cooler')
@@ -31,15 +32,16 @@ pkgver() {
prepare() {
cd $pkgname
- git submodule init wlroots-rs
- git config submodule.wlroots-rs.url ../wlroots-rs
- git submodule update --remote --init wlroots-rs
- cd ../wlroots-rs
- git submodule init wlroots-sys/wlroots
- git config submodule.wlroots.url ../wlroots
- git submodule update --init --recursive --remote wlroots-sys/wlroots/
- cd ../wlroots
- git reset --hard 79683ee497cff4e363612933af2f068cfea9b19c
+ git submodule update --init --recursive
+ #git submodule init wlroots-rs
+ #git config submodule.wlroots-rs.url ../wlroots-rs
+ #git submodule update --remote --init wlroots-rs
+ #cd ../wlroots-rs
+ #git submodule init wlroots-sys/wlroots
+ # git config submodule.wlroots.url ../wlroots
+ # git submodule update --init --recursive --remote wlroots-sys/wlroots/
+ # cd ../wlroots
+ # git reset --hard 79683ee497cff4e363612933af2f068cfea9b19c
}
build() {
cd "$srcdir/$pkgname/wlroots-rs"