summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Courtis2022-03-21 14:38:13 +1100
committerAlexander Courtis2022-03-21 14:38:13 +1100
commit97905935c1915fbe43c6fa6440bb6a3827754120 (patch)
tree6910f47317b1b38fbd3ab151655185a8d5fefade
parentb8c47520793db45838b3bfac35129ce0bc98840d (diff)
downloadaur-97905935c1915fbe43c6fa6440bb6a3827754120.tar.gz
1.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--way-displays-1_4.install33
-rw-r--r--way-displays-1_5.install59
4 files changed, 66 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab9af5a5d455..767fd2a11233 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = way-displays
pkgdesc = way-displays: Auto Manage Your Wayland Displays
- pkgver = 1.4.1
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/alex-courtis/way-displays
- install = way-displays-1_4.install
+ install = way-displays-1_5.install
arch = x86_64
license = MIT
makedepends = git
@@ -13,7 +13,7 @@ pkgbase = way-displays
depends = wlroots
depends = libinput
depends = yaml-cpp
- source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.4.1.tar.gz
- sha256sums = ea9f4e5094b40b0c909e723f12506af4e0d97cc9ef80dc3967af548aa881ca63
+ source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.5.0.tar.gz
+ sha256sums = 1ccc9643dd7ebdf2e0280f43d049aff4a47991b46992f14b425849ee8603bdc7
pkgname = way-displays
diff --git a/PKGBUILD b/PKGBUILD
index a7ad91231b1c..eb7675daea84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexander Courtis <alex@courtis.org>
pkgname=way-displays
-pkgver=1.4.1
+pkgver=1.5.0
pkgrel=1
pkgdesc="way-displays: Auto Manage Your Wayland Displays"
arch=('x86_64')
@@ -9,8 +9,8 @@ license=('MIT')
depends=('wayland' 'wlroots' 'libinput' 'yaml-cpp')
makedepends=('git' 'make' 'gcc')
source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('ea9f4e5094b40b0c909e723f12506af4e0d97cc9ef80dc3967af548aa881ca63')
-install=way-displays-1_4.install
+sha256sums=('1ccc9643dd7ebdf2e0280f43d049aff4a47991b46992f14b425849ee8603bdc7')
+install=way-displays-1_5.install
build() {
cd "$pkgname-$pkgver"
diff --git a/way-displays-1_4.install b/way-displays-1_4.install
deleted file mode 100644
index 46795e26953d..000000000000
--- a/way-displays-1_4.install
+++ /dev/null
@@ -1,33 +0,0 @@
-# Colored makepkg-like functions
-note() {
- printf "${blue}==>${yellow} NOTE:${all_off} ${1}\n"
-}
-
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-red="${bold}$(tput setaf 1)"
-green="${bold}$(tput setaf 2)"
-yellow="${bold}$(tput setaf 3)"
-blue="${bold}$(tput setaf 4)"
-
-post_install() {
- note ""
- note "${yellow}1.4.0 New Feature: Command Line Client${all_off}"
- note ""
- note "Manages the server. The active configuration and display state may be inspected, modified and written to disk."
- note ""
- note "e.g. Show current configuration and display state: ${green}way-displays -g${all_off}"
- note " Set a scale: ${green}way-displays -s SCALE \"eDP-1\" 3${all_off}"
- note " Persist your changes to your cfg.yaml: ${green}way-displays -w${all_off}"
- note ""
- note "See ${blue}man way-displays${all_off} and ${blue}way-displays --help${all_off}"
- note ""
- note "${yellow}1.4.1${all_off}"
- note " Minor safety improvements"
- note ""
-}
-
-post_upgrade() {
- post_install
-}
-
diff --git a/way-displays-1_5.install b/way-displays-1_5.install
new file mode 100644
index 000000000000..81a105275b34
--- /dev/null
+++ b/way-displays-1_5.install
@@ -0,0 +1,59 @@
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+red="${bold}$(tput setaf 1)"
+green="${bold}$(tput setaf 2)"
+yellow="${bold}$(tput setaf 3)"
+blue="${bold}$(tput setaf 4)"
+magenta="${bold}$(tput setaf 5)"
+
+# Colored makepkg-like functions
+note() {
+ printf "${blue}==>${yellow} NOTE:${all_off} ${1}\n"
+}
+
+plain() {
+ printf "${1}\n"
+}
+
+green() {
+ printf "${green}${1}${all_off}\n"
+}
+
+yello() {
+ printf "${yellow}${1}${all_off}\n"
+}
+
+blue() {
+ printf "${blue}${1}${all_off}\n"
+}
+
+magen() {
+ printf "${magenta}${1}${all_off}\n"
+}
+
+post_install() {
+ yello "1.5.0"
+ blue "New Feature: User MODE Selection"
+ plain " e.g. set HDMI-A-1 3840x2160@144Hz"
+ plain ""
+ plain " cfg.yaml"
+ magen " MODE:"
+ magen " - NAME_DESC: HDMI-A-1"
+ magen " WIDTH: 3840"
+ magen " HEIGHT: 2160"
+ magen " HZ: 144"
+ plain ""
+ plain " CLI"
+ green " way-displays -s MODE HDMI-A-1 3840 2160 144"
+ plain ""
+ blue "Laptop Lid"
+ plain " Workaround: Laptop Lid Not Closed At Startup: https://github.com/alex-courtis/way-displays#known-issues-with-workarounds"
+ plain ""
+ plain " Lid now detected at startup, before connecting to display. This results in slightly slower startup."
+ plain ""
+}
+
+post_upgrade() {
+ post_install
+}
+