summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Courtis2022-02-22 16:53:21 +1100
committerAlexander Courtis2022-02-22 16:53:21 +1100
commitf27773751dcccca81f0e486f0b8163c3e8ed1c8f (patch)
treec5479422bededbdf83b0080dceef69a93a005cee
parentd2cc7ba425ca638630b47abe0dcbaea8a6cc3971 (diff)
downloadaur-f27773751dcccca81f0e486f0b8163c3e8ed1c8f.tar.gz
1.4.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--way-displays-1_3.install31
-rw-r--r--way-displays-1_4.install30
4 files changed, 38 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bdb0aea28f2..c89733ad6a2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = way-displays
pkgdesc = way-displays: Auto Manage Your Wayland Displays
- pkgver = 1.3.0
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/alex-courtis/way-displays
- install = way-displays-1_3.install
+ install = way-displays-1_4.install
arch = x86_64
license = MIT
makedepends = git
@@ -13,7 +13,7 @@ pkgbase = way-displays
depends = wlroots
depends = libinput
depends = yaml-cpp
- source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.3.0.tar.gz
- sha256sums = 4a757f079e14bcfcd2804fed0a4a6190535ae059b45e3d73e5b298bba306201b
+ source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.4.0.tar.gz
+ sha256sums = 0514e79fe113ebee02b3ca338336d10cf94d9ebf2e7bdb798dc48a3ca157ae28
pkgname = way-displays
diff --git a/PKGBUILD b/PKGBUILD
index 5a530f4c9ccb..60d848be70ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexander Courtis <alex@courtis.org>
pkgname=way-displays
-pkgver=1.3.0
+pkgver=1.4.0
pkgrel=1
pkgdesc="way-displays: Auto Manage Your Wayland Displays"
arch=('x86_64')
@@ -8,9 +8,9 @@ url="https://github.com/alex-courtis/way-displays"
license=('MIT')
depends=('wayland' 'wlroots' 'libinput' 'yaml-cpp')
makedepends=('git' 'make' 'gcc')
-source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/1.3.0.tar.gz")
-sha256sums=('4a757f079e14bcfcd2804fed0a4a6190535ae059b45e3d73e5b298bba306201b')
-install=way-displays-1_3.install
+source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/1.4.0.tar.gz")
+sha256sums=('0514e79fe113ebee02b3ca338336d10cf94d9ebf2e7bdb798dc48a3ca157ae28')
+install=way-displays-1_4.install
build() {
cd "$pkgname-$pkgver"
diff --git a/way-displays-1_3.install b/way-displays-1_3.install
deleted file mode 100644
index 0c855c867d48..000000000000
--- a/way-displays-1_3.install
+++ /dev/null
@@ -1,31 +0,0 @@
-# Colored makepkg-like functions
-note() {
- printf "${blue}==>${yellow} NOTE:${all_off} ${1}\n"
-}
-
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-red="${bold}$(tput setaf 1)"
-green="${bold}$(tput setaf 2)"
-yellow="${bold}$(tput setaf 3)"
-blue="${bold}$(tput setaf 4)"
-
-post_install() {
- note ""
- note "${yellow}1.3.0 New Feature #16 Disabled Displays${all_off}"
- note ""
- note "Optional cfg.yaml additions:"
- note ""
- note "# Disable the specified displays."
- note "# To disable/enable on-the-fly see recipe: https://github.com/alex-courtis/way-displays#on-the-fly-recipes"
- note "${red}DISABLED${all_off}:"
- note "${yellow} - ${green}'eDP-1'${all_off}"
- note ""
- note "For full details see https://github.com/alex-courtis/way-displays and /etc/way-displays/cfg.yaml"
- note ""
-}
-
-post_upgrade() {
- post_install
-}
-
diff --git a/way-displays-1_4.install b/way-displays-1_4.install
new file mode 100644
index 000000000000..f429dd2326f6
--- /dev/null
+++ b/way-displays-1_4.install
@@ -0,0 +1,30 @@
+# Colored makepkg-like functions
+note() {
+ printf "${blue}==>${yellow} NOTE:${all_off} ${1}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+red="${bold}$(tput setaf 1)"
+green="${bold}$(tput setaf 2)"
+yellow="${bold}$(tput setaf 3)"
+blue="${bold}$(tput setaf 4)"
+
+post_install() {
+ note ""
+ note "${yellow}1.4.0 New Feature: Command Line Client${all_off}"
+ note ""
+ note "Manages the server. The active configuration and display state may be inspected, modified and written to disk."
+ note ""
+ note "e.g. Show current configuration and display state: ${green}way-displays -g${all_off}"
+ note " Set a scale: ${green}way-displays -s SCALE \"eDP-1\" 3${all_off}"
+ note " Persist your changes to your cfg.yaml: ${green}way-displays -w${all_off}"
+ note ""
+ note "See ${blue}man way-displays${all_off} and ${blue}way-displays --help${all_off}"
+ note ""
+}
+
+post_upgrade() {
+ post_install
+}
+