summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Courtis2021-11-04 13:29:54 +1100
committerAlexander Courtis2021-11-04 13:29:54 +1100
commitf9d8175389130d215fff73b0af3c7de61355b786 (patch)
tree37fd50c5543b03cb4d14fd407858b9dd41a5cf53
parent22c095270eec33e17a622e3812759d755c0889bb (diff)
downloadaur-f9d8175389130d215fff73b0af3c7de61355b786.tar.gz
1.1.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--way-displays-1_1_0.install32
3 files changed, 40 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1f0c5ddcd12..c71e776d6a07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = way-displays
pkgdesc = way-displays: Auto Manage Your Wayland Displays
- pkgver = 1.0.2
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/alex-courtis/way-displays
+ install = way-displays-1_1_0.install
arch = x86_64
license = MIT
makedepends = git
@@ -12,7 +13,7 @@ pkgbase = way-displays
depends = wlroots
depends = libinput
depends = yaml-cpp
- source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.0.2.tar.gz
- sha256sums = b5ce6cf1316746183f4856801e956df0d0b9012e089a96f7611667af62b602d8
+ source = https://github.com/alex-courtis/way-displays/archive/refs/tags/1.1.0.tar.gz
+ sha256sums = 29f712c52efd971264f3b49f896f3c73e9c5726430c8a03c234825ed9fb84641
pkgname = way-displays
diff --git a/PKGBUILD b/PKGBUILD
index 571f2c4c57b0..cbb982a175af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexander Courtis <alex@courtis.org>
pkgname=way-displays
-pkgver=1.0.2
+pkgver=1.1.0
pkgrel=1
pkgdesc="way-displays: Auto Manage Your Wayland Displays"
arch=('x86_64')
@@ -8,8 +8,9 @@ url="https://github.com/alex-courtis/way-displays"
license=('MIT')
depends=('wayland' 'wlroots' 'libinput' 'yaml-cpp')
makedepends=('git' 'make' 'gcc')
-source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/1.0.2.tar.gz")
-sha256sums=('b5ce6cf1316746183f4856801e956df0d0b9012e089a96f7611667af62b602d8')
+source=("https://github.com/alex-courtis/way-displays/archive/refs/tags/1.1.0.tar.gz")
+sha256sums=('29f712c52efd971264f3b49f896f3c73e9c5726430c8a03c234825ed9fb84641')
+install=way-displays-1_1_0.install
build() {
cd "$pkgname-$pkgver"
diff --git a/way-displays-1_1_0.install b/way-displays-1_1_0.install
new file mode 100644
index 000000000000..da9b16cac8d9
--- /dev/null
+++ b/way-displays-1_1_0.install
@@ -0,0 +1,32 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+red="${bold}$(tput setaf 1)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "1.1.0 New Feature: arrange and align displays."
+ note ""
+ note "Optional cfg.yaml additions:"
+ note "${all_off}# Arrange displays in a ROW (default, left to right) or a COLUMN (top to bottom)"
+ note "${red}ARRANGE${all_off}: ${bold}ROW"
+ note "${all_off}# Align ROWs at the TOP (default), MIDDLE or BOTTOM"
+ note "${all_off}# Align COLUMNs at the LEFT (default), MIDDLE or RIGHT"
+ note "${red}ALIGN${all_off}: ${bold}TOP"
+ note ""
+ note "For full details see https://github.com/alex-courtis/way-displays and /etc/way-displays/cfg.yaml"
+}
+
+post_upgrade() {
+ post_install
+}
+