diff options
author | caltlgin | 2020-09-30 15:52:55 +1300 |
---|---|---|
committer | caltlgin | 2020-09-30 15:52:55 +1300 |
commit | 331ed55e8b15922c0c29bcd334890a98fd978967 (patch) | |
tree | 837afc01454237276d1e717b6e15e6cdf6b46575 | |
parent | 222fc0fbdd964427f159a24fec27be658ff80c0b (diff) | |
download | aur-331ed55e8b15922c0c29bcd334890a98fd978967.tar.gz |
Add "go clean -modcache"
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | PKGBUILD | 15 |
2 files changed, 10 insertions, 7 deletions
@@ -9,7 +9,7 @@ pkgbase = waybackurls-git makedepends = go provides = waybackurls source = git+https://github.com/tomnomnom/waybackurls.git - source = waybackurls-0.0.2.r6.g89da10c-LICENSE::https://raw.githubusercontent.com/tomnomnom/gron/master/LICENSE + source = waybackurls-0.0.2.r6.g89da10c-LICENSE::https://github.com/tomnomnom/gron/raw/master/LICENSE sha256sums = SKIP sha256sums = SKIP @@ -1,22 +1,26 @@ # Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz> -_pkgname=waybackurls -pkgname=${_pkgname}-git +_pkgname='waybackurls' +pkgname="${_pkgname}-git" pkgver=0.0.2.r6.g89da10c pkgrel=3 pkgdesc='Fetch all the URLs that the Wayback Machine knows about for a domain' arch=('x86_64') url='https://github.com/tomnomnom/waybackurls' -# License from gron as per https://github.com/BlackArch/blackarch/blob/master/packages/waybackurls/PKGBUILD#L27 -_rawurl="https://raw.githubusercontent.com/tomnomnom/gron" license=('MIT') makedepends=('git' 'go') provides=("${_pkgname}") +# License from gron as per https://github.com/BlackArch/blackarch/blob/master/packages/waybackurls/PKGBUILD#L27 source=("git+${url}.git" - "${_pkgname}-${pkgver}-LICENSE::${_rawurl}/master/LICENSE") + "${_pkgname}-${pkgver}-LICENSE::${url%/*}/gron/raw/master/LICENSE") sha256sums=('SKIP' 'SKIP') +prepare() { + export GOPATH="${srcdir}/gopath" + go clean -modcache +} + pkgver() { git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' } @@ -27,7 +31,6 @@ build() { export CGO_CXXFLAGS="${CXXFLAGS}" export CGO_LDFLAGS="${LDFLAGS}" export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" - export GOPATH="${srcdir}" cd "${_pkgname}" go build -v -o "${_pkgname}" main.go |