summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Plaçais2018-08-09 20:40:35 +0200
committerThomas Plaçais2018-08-09 20:40:35 +0200
commit9cf405e57c27d13acab4a9a7726c56511aca98bb (patch)
tree2a685acd3bb89f45f9859e68567bdda3c6b3b85a
downloadaur-9cf405e57c27d13acab4a9a7726c56511aca98bb.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
-rw-r--r--meson.build.patch8
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc0a5b500b54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = waybar-git
+ pkgdesc = Highly customizable wayland bar for sway or wlroots based compositor.
+ pkgver = r32.03132bd2
+ pkgrel = 1
+ url = https://github.com/Alexays/Waybar/
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ depends = gtkmm3
+ depends = jsoncpp
+ depends = libinput
+ depends = libnl>=3.0
+ depends = libsigc++>=2.0
+ depends = wayland
+ depends = wlroots
+ source = waybar-git::git://github.com/Alexays/Waybar
+ source = meson.build.patch
+ sha1sums = SKIP
+ sha1sums = 36bd667affd6f5e3ca3e15665f7af2ea8438eda7
+
+pkgname = waybar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6e05998d832
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alexis Rouillard <contact@arouillard.fr>
+
+pkgname=waybar-git
+pkgver=r32.03132bd2
+pkgrel=1
+pkgdesc='Highly customizable wayland bar for sway or wlroots based compositor.'
+arch=('x86_64')
+url='https://github.com/Alexays/Waybar/'
+license=('MIT')
+depends=('gtkmm3'
+ 'jsoncpp'
+ 'libinput'
+ 'libnl>=3.0'
+ 'libsigc++>=2.0'
+ 'wayland'
+ 'wlroots')
+makedepends=('meson')
+source=("${pkgname}::git://github.com/Alexays/Waybar"
+ 'meson.build.patch')
+sha1sums=('SKIP'
+ '36bd667affd6f5e3ca3e15665f7af2ea8438eda7')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch meson.build "${srcdir}/meson.build.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ rm -rf "${srcdir}/build"
+ meson --wrap-mode=nofallback --prefix=/usr "${srcdir}/build"
+ ninja -C "${srcdir}/build"
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C "${srcdir}/build" install
+}
diff --git a/meson.build.patch b/meson.build.patch
new file mode 100644
index 000000000000..fa3492acc058
--- /dev/null
+++ b/meson.build.patch
@@ -0,0 +1,8 @@
+1c1
+< project('waybar', 'cpp', 'c', default_options : ['cpp_std=c++17'])
+---
+> project('waybar', 'cpp', 'c', default_options : ['cpp_std=c++17', 'default_library=static'])
+21c21
+< fmt = dependency('fmt', fallback: ['fmtlib', 'fmt_dep'])
+---
+> fmt = subproject('fmtlib').get_variable('fmt_dep')