summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Ancona2023-04-18 17:41:02 -0600
committerBruno Ancona2023-04-18 17:41:02 -0600
commit227ac1a905e1429f528614c537fea90a417b9df1 (patch)
tree7d9cb82535468b90a6097de62dc22a8010c1832c
parent1ec549866eba42ae47920da6be4519d06962ca1c (diff)
downloadaur-227ac1a905e1429f528614c537fea90a417b9df1.tar.gz
Remove cava module
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--cava.patch21
3 files changed, 5 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6587e03b9550..d4b4490ebd3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waybar-hyprland-git
pkgdesc = Highly customizable Wayland bar for Sway and Wlroots based compositors, with workspaces support for Hyprland (git version)
- pkgver = 0.9.17.r134.g8aafe817
+ pkgver = 0.9.17.r159.ga9a22234
pkgrel = 1
url = https://github.com/Alexays/Waybar/
arch = x86_64
@@ -44,9 +44,7 @@ pkgbase = waybar-hyprland-git
backup = etc/xdg/waybar/style.css
source = waybar-hyprland-git::git+https://github.com/Alexays/Waybar
source = hyprctl.patch
- source = cava.patch
sha256sums = SKIP
sha256sums = b4819ed456b27c355f24c460bcf3ff2fec6dade8c210263b64361c6744a9147c
- sha256sums = 51fbf6cf8767cebf66e26b8f393e696859ef02c70ad7c88fe55025534e2515ab
pkgname = waybar-hyprland-git
diff --git a/PKGBUILD b/PKGBUILD
index f3bc1f2cbd8f..d3be94d46d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bruno Ancona <bruno at powerball253 dot com>
pkgname=waybar-hyprland-git
-pkgver=0.9.17.r134.g8aafe817
+pkgver=0.9.17.r159.ga9a22234
pkgrel=1
pkgdesc='Highly customizable Wayland bar for Sway and Wlroots based compositors, with workspaces support for Hyprland (git version)'
arch=('x86_64' 'aarch64')
@@ -51,11 +51,9 @@ optdepends=(
'cava: Cava plugin support'
)
source=("${pkgname}::git+https://github.com/Alexays/Waybar"
- hyprctl.patch
- cava.patch)
+ hyprctl.patch)
sha256sums=('SKIP'
- 'b4819ed456b27c355f24c460bcf3ff2fec6dade8c210263b64361c6744a9147c'
- '51fbf6cf8767cebf66e26b8f393e696859ef02c70ad7c88fe55025534e2515ab')
+ 'b4819ed456b27c355f24c460bcf3ff2fec6dade8c210263b64361c6744a9147c')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -64,14 +62,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
-
git apply ../hyprctl.patch # use hyprctl to switch workspaces
- git apply ../cava.patch # fix cava dependency not found
-
- mkdir "subprojects/packagecache"
- filename=$(grep source_filename subprojects/cava.wrap | rev | cut -d' ' -f1 | rev)
- url=$(grep source_url subprojects/cava.wrap | rev | cut -d' ' -f1 | rev)
- curl -Lo "subprojects/packagecache/${filename}" "$url" # pre=download cava dependency
}
build() {
@@ -83,6 +74,7 @@ build() {
--auto-features=enabled \
--wrap-mode=nodownload \
-Dexperimental=true \
+ -Dcava=disabled \
"${srcdir}/build"
ninja -C "${srcdir}/build"
}
diff --git a/cava.patch b/cava.patch
deleted file mode 100644
index 3baf93e41787..000000000000
--- a/cava.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/meson.build b/meson.build
-index f2515bf8..16528a79 100644
---- a/meson.build
-+++ b/meson.build
-@@ -336,13 +336,9 @@ if get_option('experimental')
- add_project_arguments('-DUSE_EXPERIMENTAL', language: 'cpp')
- endif
-
--cava = compiler.find_library('cava',
-- required: get_option('cava'))
--if not cava.found() and not get_option('cava').disabled()
-- cava = dependency('cava',
-- required: false,
-- fallback: [ 'cava', 'cava_dep' ])
--endif
-+cava = dependency('cava',
-+ required: false,
-+ fallback: [ 'cava', 'cava_dep' ])
-
- if cava.found()
- add_project_arguments('-DHAVE_LIBCAVA', language: 'cpp')