summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Ancona2023-07-04 19:20:25 -0600
committerBruno Ancona2023-07-04 19:20:25 -0600
commit4da0f983b9061f4db390dccc6264e6599a3ae009 (patch)
tree28c03b68a93309706c4f37e6687ab1f280b67d84
parent2ab38867f3951078805dd7d24aa1d31ea7d8fa1c (diff)
downloadaur-4da0f983b9061f4db390dccc6264e6599a3ae009.tar.gz
Re-add hyprctl patch until upstream is fixed
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2dff095829f..5b00812ebfbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waybar-hyprland-git
pkgdesc = Highly customizable Wayland bar for Sway and Wlroots based compositors, with workspaces support for Hyprland (git version)
- pkgver = 0.9.18.r46.g41164905
+ pkgver = 0.9.19.r2.ge7deab92
pkgrel = 1
url = https://github.com/Alexays/Waybar/
arch = x86_64
@@ -37,11 +37,14 @@ pkgbase = waybar-hyprland-git
depends = wireplumber
depends = playerctl
optdepends = otf-font-awesome: Icons in the default configuration
+ optdepends = cava: Cava plugin support
provides = waybar
conflicts = waybar
backup = etc/xdg/waybar/config
backup = etc/xdg/waybar/style.css
source = waybar-hyprland-git::git+https://github.com/Alexays/Waybar
+ source = hyprctl.patch
sha256sums = SKIP
+ sha256sums = b4819ed456b27c355f24c460bcf3ff2fec6dade8c210263b64361c6744a9147c
pkgname = waybar-hyprland-git
diff --git a/PKGBUILD b/PKGBUILD
index 4765acf4d886..1e35ab574c71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bruno Ancona <bruno at powerball253 dot com>
pkgname=waybar-hyprland-git
-pkgver=0.9.18.r46.g41164905
+pkgver=0.9.19.r2.ge7deab92
pkgrel=1
pkgdesc='Highly customizable Wayland bar for Sway and Wlroots based compositors, with workspaces support for Hyprland (git version)'
arch=('x86_64' 'aarch64')
@@ -48,15 +48,23 @@ backup=(
)
optdepends=(
'otf-font-awesome: Icons in the default configuration'
+ 'cava: Cava plugin support'
)
-source=("${pkgname}::git+https://github.com/Alexays/Waybar")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/Alexays/Waybar"
+ hyprctl.patch)
+sha256sums=('SKIP'
+ 'b4819ed456b27c355f24c460bcf3ff2fec6dade8c210263b64361c6744a9147c')
pkgver() {
cd "${srcdir}/${pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git apply ../hyprctl.patch # use hyprctl to switch workspaces
+}
+
build() {
cd "${srcdir}/${pkgname}"
rm -rf "${srcdir}/build"