summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRustacean2023-06-28 19:30:55 +0200
committerRustacean2023-06-28 19:30:55 +0200
commit777355fe24b004121cf3d73c326bd491b0106cab (patch)
tree0f534daa3f8ba504b94b6c0c15b156f64059c7bb
parent92551dccf24c724a19937871fea029b16666861a (diff)
downloadaur-777355fe24b004121cf3d73c326bd491b0106cab.tar.gz
add stdexcept and string includes required by gcc13
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36e00addd88c..4e7a5fecea51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,6 +60,7 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
sed -i 's/zext_workspace_handle_v1_activate(workspace_handle_);/const std::string command = "hyprctl dispatch workspace " + name_;\n\tsystem(command.c_str());/g' src/modules/wlr/workspace_manager.cpp # use hyprctl to switch workspaces
+ sed -i '10 i #include <stdexcept>\n#include <string>' include/modules/sway/ipc/client.hpp
meson --prefix=/usr \
--buildtype=plain \