summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Boyd Isacsson2021-01-11 13:20:35 +0100
committerNicholas Boyd Isacsson2021-01-11 13:20:35 +0100
commit54c86fe8b47fe95bae8aacb993da1f23ad433805 (patch)
tree6859715a32116fa051a5e2fe477e002e698fb148
downloadaur-54c86fe8b47fe95bae8aacb993da1f23ad433805.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0522790b20f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = waybar-mpris-git
+ pkgdesc = MPRIS2 waybar component
+ pkgver = r29.937769e
+ pkgrel = 1
+ url = https://git.hrfee.pw/hrfee/waybar-mpris
+ arch = any
+ license = unknown
+ makedepends = go
+ source = git+https://git.hrfee.pw/hrfee/waybar-mpris
+ md5sums = SKIP
+
+pkgname = waybar-mpris-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15d94bb77861
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nicholas Boyd Isacsson <nicholas@isacsson.se>
+
+pkgname=waybar-mpris-git
+_pkgname=waybar-mpris
+pkgver=r29.937769e
+pkgrel=1
+pkgdesc='MPRIS2 waybar component'
+arch=('any')
+url="https://git.hrfee.pw/hrfee/$_pkgname"
+license=('unknown')
+depends=()
+makedepends=('go')
+source=(git+$url)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ cd "$_pkgname"
+ go build
+}
+
+package() {
+ cd "$_pkgname"
+ install -vDm 755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+}