summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Schulte2020-07-13 11:19:23 +0200
committerNils Schulte2020-07-13 11:19:23 +0200
commit9578c3f6d007c9306078dcf84aa43e7d25d82bc3 (patch)
treed426be2e9cf4990155ee610b08e14f4403c028af
downloadaur-9578c3f6d007c9306078dcf84aa43e7d25d82bc3.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd6a23e1e8ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = waybind-git
+ pkgdesc = Simple Key rebinder
+ pkgver = v0.1.1.r2.g2e976d7
+ pkgrel = 1
+ url = https://github.com/arnarg/waybind
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ provides = waybind
+ conflicts = waybind
+ source = waybind::git+https://github.com/arnarg/waybind
+ sha512sums = SKIP
+
+pkgname = waybind-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b96fb73181ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nils Schulte <aur@nilsschulte.de>
+
+pkgname=waybind-git
+_pkgname=waybind
+pkgver=v0.1.1.r2.g2e976d7
+pkgrel=1
+pkgdesc='Simple Key rebinder'
+arch=('x86_64')
+url='https://github.com/arnarg/waybind'
+license=('MIT')
+makedepends=('git' 'go')
+provides=('waybind')
+conflicts=('waybind')
+source=("$_pkgname::git+https://github.com/arnarg/waybind")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make PREFIX=/usr VERSION="$(pkgver)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p "${pkgdir}/usr/bin/"
+ mv waybind "${pkgdir}/usr/bin/waybind"
+}