summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarnabe2022-10-08 00:07:27 -0300
committerBarnabe2022-10-08 00:07:27 -0300
commit9be3d3854a4270a67b8debf2e69fb387e8008f07 (patch)
tree00a76c6d3a6e6274d3f648d0ef2ef0ecdefa608f
downloadaur-waydroid-biglinux.tar.gz
fist
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..491b1fa39f0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = waydroid-biglinux
+ pkgdesc = Simplify waydroid usage
+ pkgver = 22.10.08
+ pkgrel = 0007
+ url = https://github.com/biglinux/waydroid-biglinux
+ arch = any
+ license = GPL
+ depends = waydroid
+ depends = python-pyclip
+ depends = bigbashview
+ source = git+https://github.com/biglinux/waydroid-biglinux.git
+ md5sums = SKIP
+
+pkgname = waydroid-biglinux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8c502550068
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bruno Goncalves <bigbruno@gmail.com>
+
+pkgname=waydroid-biglinux
+pkgver=$(date +%y.%m.%d)
+pkgrel=$(date +%H%M)
+arch=('any')
+license=('GPL')
+url="https://github.com/biglinux/waydroid-biglinux"
+pkgdesc="Simplify waydroid usage"
+source=("git+https://github.com/biglinux/waydroid-biglinux.git")
+depends=(waydroid python-pyclip bigbashview)
+md5sums=(SKIP)
+
+package() {
+ # Verify default folder
+ if [ -d "${srcdir}/${pkgname}/${pkgname}" ]; then
+ InternalDir="${srcdir}/${pkgname}/${pkgname}"
+ else
+ InternalDir="${srcdir}/${pkgname}"
+ fi
+
+
+ # Copy files
+ if [ -d "${InternalDir}/usr" ]; then
+ cp -r "${InternalDir}/usr" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/etc" ]; then
+ cp -r "${InternalDir}/etc" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/opt" ]; then
+ cp -r "${InternalDir}/opt" "${pkgdir}/"
+ fi
+}