summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2021-02-01 12:52:52 +0200
committerAdrian Perez de Castro2021-02-01 12:52:52 +0200
commit73f9b77d846fb24e0feb793b401bf29705ad6d01 (patch)
tree60a7c13230218c49ad3fb204e29d70f6097434dd
parent177fb87b01fcd4daf430909d6c80ffa8b0281abb (diff)
downloadaur-73f9b77d846fb24e0feb793b401bf29705ad6d01.tar.gz
Bump to version 0.7.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6af837bd8635..8c4fa9f22d2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wayfire
pkgdesc = 3D wayland compositor
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://wayfire.org
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = wayfire
depends = wlroots>=0.12
depends = wlroots<0.13
conflicts = wayfire-git
- source = https://github.com/WayfireWM/wayfire/releases/download/0.6.0/wayfire-0.6.0.tar.xz
- sha256sums = 98a903eb3174834bb09d957987948a5fc8447661cf2dda48260db947f5d78571
+ source = https://github.com/WayfireWM/wayfire/releases/download/v0.7.0/wayfire-0.7.0.tar.xz
+ sha256sums = 0d8ec311510bf10647d857c2db6e3dbbccfe3ac9064463661c8062c8cbb469a6
pkgname = wayfire
diff --git a/PKGBUILD b/PKGBUILD
index e1dd9a54fa94..debf66cf3b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=wayfire
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="3D wayland compositor"
arch=(x86_64)
@@ -9,12 +9,12 @@ license=(custom:MIT)
depends=(cairo 'wf-config>=0.5' libjpeg libinput 'wlroots>=0.12' 'wlroots<0.13')
makedepends=(meson ninja wayland-protocols glm)
conflicts=("${pkgname}-git")
-source=("https://github.com/WayfireWM/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz")
-sha256sums=(98a903eb3174834bb09d957987948a5fc8447661cf2dda48260db947f5d78571)
+source=("https://github.com/WayfireWM/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=(0d8ec311510bf10647d857c2db6e3dbbccfe3ac9064463661c8062c8cbb469a6)
build() {
rm -rf build
- arch-meson "${pkgname}-${pkgver}" build
+ arch-meson "${pkgname}-${pkgver}" build -Duse_system_wfconfig=enabled -Duse_system_wlroots=enabled
ninja -C build
}