summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2024-02-18 15:58:35 -0500
committerSolomon Choina2024-02-18 15:58:35 -0500
commit4221fb06ca9a83106200a9e8b6151b320691652f (patch)
treeb2ca6b8578f692aa69df032404f5739198c4ff23
parent703e1ef02ab85b7561a31280d8d3cc01819f0778 (diff)
downloadaur-wayfire-git.tar.gz
updating pkgver and fixing build
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
2 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac3e60d38a49..42e0a9c58721 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wayfire-git
pkgdesc = 3D wayland compositor
- pkgver = 0.7.4.r214.gda7a929c
+ pkgver = 0.8.0.r102.g906a3105
pkgrel = 1
url = https://github.com/WayfireWM/wayfire
arch = x86_64
@@ -11,12 +11,14 @@ pkgbase = wayfire-git
makedepends = ninja
makedepends = cmake
makedepends = vulkan-headers
+ makedepends = doctest
+ makedepends = pkgconf
+ makedepends = wayland-protocols
+ makedepends = nlohmann-json
+ makedepends = libxml2
+ makedepends = glm
depends = cairo
depends = pango
- depends = doctest
- depends = freetype2
- depends = glm
- depends = nlohmann-json
depends = libdrm
depends = libevdev
depends = libglvnd
@@ -24,29 +26,23 @@ pkgbase = wayfire-git
depends = libjpeg
depends = libpng
depends = libxkbcommon
- depends = libxml2
depends = pixman
depends = polkit
- depends = pkgconf
depends = seatd
depends = xcb-util-errors
depends = xcb-util-renderutil
depends = xcb-util-wm
depends = xorg-xwayland
depends = wayland
- depends = wayland-protocols
+ depends = libdisplay-info
+ depends = wf-config-git
optdepends = xorg-xeyes
provides = wayfire
provides = wlroots
- provides = wf-config
provides = wlroots-git
- provides = wf-config-git
provides = libwlroots.so
- conflicts = wayfire-git
+ conflicts = wayfire
conflicts = wlroots-git
- conflicts = wlroots
- conflicts = wf-config-git
- conflicts = wf-config
source = git+https://github.com/WayfireWM/wayfire
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7e02f34ac414..d41575ac5296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
# Co-Maintainer: Frank Tao <frank.tao@uwaterloo.ca>
pkgname=wayfire-git
-pkgver=0.7.4.r214.gda7a929c
+pkgver=0.8.0.r102.g906a3105
pkgrel=1
pkgdesc="3D wayland compositor"
arch=('x86_64')
url="https://github.com/WayfireWM/wayfire"
-license=('MIT')
-depends=('cairo' 'pango' 'doctest' 'freetype2' 'glm' 'nlohmann-json'
- 'libdrm' 'libevdev' 'libglvnd' 'libinput' 'libjpeg'
- 'libpng' 'libxkbcommon' 'libxml2' 'pixman' 'polkit'
- 'pkgconf' 'seatd' 'xcb-util-errors' 'xcb-util-renderutil'
- 'xcb-util-wm' 'xorg-xwayland' 'wayland' 'wayland-protocols')
-makedepends=('git' 'glslang' 'meson' 'ninja' 'cmake' 'vulkan-headers')
+license=(MIT)
+depends=('cairo' 'pango' 'libdrm' 'libevdev'
+ 'libglvnd' 'libinput' 'libjpeg'
+ 'libpng' 'libxkbcommon' 'pixman' 'polkit'
+ 'seatd' 'xcb-util-errors' 'xcb-util-renderutil'
+ 'xcb-util-wm' 'xorg-xwayland' 'wayland'
+ 'libdisplay-info' 'wf-config-git')
+makedepends=('git' 'glslang' 'meson' 'ninja' 'cmake' 'vulkan-headers' 'doctest' 'pkgconf' 'wayland-protocols'
+ 'nlohmann-json' 'libxml2' 'glm'
+ )
optdepends=('xorg-xeyes')
-provides=("${pkgname%-git}" 'wlroots' 'wf-config' 'wlroots-git' 'wf-config-git' 'libwlroots.so')
-conflicts=("$pkgname" 'wlroots-git' 'wlroots' 'wf-config-git' 'wf-config')
+provides=("${pkgname%-git}" 'wlroots' 'wlroots-git' 'libwlroots.so')
+conflicts=("${pkgname%-git}" 'wlroots-git')
replaces=()
options=()
@@ -34,7 +37,7 @@ build() {
--buildtype=release \
-Dxwayland=auto \
-Duse_system_wlroots=disabled \
- -Duse_system_wfconfig=disabled \
+ -Duse_system_wfconfig=enabled \
-Db_lto=true \
-Db_pie=true \
build
@@ -48,4 +51,6 @@ package() {
DESTDIR="$pkgdir/" ninja -C build install
install -Dm644 wayfire.desktop $pkgdir/usr/share/wayland-sessions/wayfire.desktop
cp wayfire.ini $pkgdir/usr/share
+ install -Dm644 "LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}