summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2022-03-05 22:16:17 -0500
committerSolomon Choina2022-03-05 22:16:17 -0500
commit540e0e132c2a7f619657845849d91b008c479e0a (patch)
treea34c156338639056734f77910c94e1abd776366c
parent47ec58707cc8e279bb7263354a5907ae910ea827 (diff)
downloadaur-540e0e132c2a7f619657845849d91b008c479e0a.tar.gz
fixing the pkgver stuff
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb6592148eb8..7615ccd2a1a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wayfire-git
pkgdesc = 3D wayland compositor
- pkgver = 0.7.2.r20220103.0a921f7
- pkgrel = 2
+ pkgver = 0.7.2.r191.g9458f589
+ pkgrel = 1
url = https://github.com/WayfireWM/wayfire
arch = x86_64
license = MIT
@@ -28,7 +28,6 @@ pkgbase = wayfire-git
depends = polkit
depends = pkgconf
depends = seatd
- depends = libinput
depends = xcb-util-errors
depends = xcb-util-renderutil
depends = xcb-util-wm
@@ -37,13 +36,13 @@ pkgbase = wayfire-git
depends = wayland-protocols
optdepends = xorg-xeyes
provides = wayfire
- provides = wlroots
- provides = wf-config
- conflicts = wayfire
- conflicts = wlroots
- conflicts = wf-config
+ provides = wlroots-git
+ provides = wf-config-git
+ conflicts = wayfire-git
conflicts = wlroots-git
+ conflicts = wlroots
conflicts = wf-config-git
+ conflicts = wf-config
source = git+https://github.com/WayfireWM/wayfire
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d023b5b3a68c..a409ddfb9411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
# Co-Maintainer: Frank Tao <frank.tao@uwaterloo.ca>
pkgname=wayfire-git
-pkgver=0.7.2.r20220103.0a921f7
-pkgrel=2
+pkgver=0.7.2.r191.g9458f589
+pkgrel=1
pkgdesc="3D wayland compositor"
arch=('x86_64')
url="https://github.com/WayfireWM/wayfire"
@@ -14,12 +14,14 @@ provides=("${pkgname%-git}" 'wlroots-git' 'wf-config-git')
conflicts=("$pkgname" 'wlroots-git' 'wlroots' 'wf-config-git' 'wf-config')
replaces=()
options=()
+
source=('git+https://github.com/WayfireWM/wayfire')
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/wayfire"
- git tag -l | awk '/^[0-9.]+$/ {print $0} /^v{1}[0-9.]+$/ {print substr($0,2)}'|sort -n|tail -n1
+ tag=$(git tag -l | awk '/^[0-9.]+$/ {print $0} /^v{1}[0-9.]+$/ {print substr($0,2)}'|sort -n|tail -n1)
+ printf "$tag.r%s.g%s" "$(git rev-list --count v${tag}..HEAD)" "$(git rev-parse --short HEAD)"
}
build() {