summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkugelblitz22022-01-03 09:10:46 -0500
committerkugelblitz22022-01-03 09:10:46 -0500
commit8823ffebb29b63623b32aaabee06b27478ee2835 (patch)
tree09101d31fc69fda07a4f77a78345c7ea08b58683
parent9c42cba639714874f6af57c346d51d548cf91caf (diff)
downloadaur-8823ffebb29b63623b32aaabee06b27478ee2835.tar.gz
Added suggestions from @lama_reborn
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD45
2 files changed, 50 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07bf7c728a77..da6524bd1622 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,43 @@
pkgbase = wayfire-git
pkgdesc = 3D wayland compositor
- pkgver = 0.7.2.r20211129.bbe63a7
- pkgrel = 2
- url = https://github.com/ammen99/wayfire
+ pkgver = 0.7.2.r20220103.0a921f7
+ pkgrel = 1
+ url = https://github.com/WayfireWM/wayfire
arch = x86_64
license = MIT
makedepends = git
- makedepends = glm
makedepends = meson
makedepends = ninja
- makedepends = wayland-protocols
- makedepends = doctest
makedepends = cmake
- depends = wlroots-git
depends = cairo
+ depends = pango
+ depends = freetype2
+ depends = glm
+ depends = libdrm
+ depends = libevdev
+ depends = libglvnd
+ depends = libinput
depends = libjpeg
- depends = wf-config-git
+ depends = libpng
+ depends = libxkbcommon
+ depends = libxml2
+ depends = pixman
+ depends = polkit
+ depends = pkgconf
depends = seatd
depends = libinput
- depends = pango
- depends = polkit
+ depends = wayland
+ depends = wayland-protocols
+ optdepends = xorg-xwayland
+ optdepends = xorg-xeyes
provides = wayfire
+ provides = wlroots
+ provides = wf-config
conflicts = wayfire
+ conflicts = wlroots
+ conflicts = wf-config
+ conflicts = wlroots-git
+ conflicts = wf-config-git
source = git+https://github.com/WayfireWM/wayfire
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 78bbe17d59ff..1e978ce1a8a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
# Co-Maintainer: Frank Tao <frank.tao@uwaterloo.ca>
pkgname=wayfire-git
-pkgver=0.7.2.r20211129.bbe63a7
-pkgrel=2
+pkgver=0.7.2.r20220103.0a921f7
+pkgrel=1
pkgdesc="3D wayland compositor"
arch=('x86_64')
-url="https://github.com/ammen99/wayfire"
+url="https://github.com/WayfireWM/wayfire"
license=('MIT')
-depends=('wlroots-git' 'cairo' 'libjpeg' 'wf-config-git' 'seatd' 'libinput' 'pango' 'polkit')
-makedepends=('git' 'glm' 'meson' 'ninja' 'wayland-protocols' 'doctest' 'cmake')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+depends=('cairo' 'pango' 'freetype2' 'glm' 'libdrm' 'libevdev' 'libglvnd' 'libinput' 'libjpeg' 'libpng' 'libxkbcommon' 'libxml2' 'pixman' 'polkit' 'pkgconf' 'seatd' 'wayland' 'wayland-protocols')
+makedepends=('git' 'meson' 'ninja' 'cmake')
+optdepends=('xorg-xwayland' 'xorg-xeyes')
+provides=("${pkgname%-git}" 'wlroots-git' 'wf-config-git')
+conflicts=("$pkgname" 'wlroots-git' 'wlroots' 'wf-config-git' 'wf-config')
replaces=()
options=()
source=('git+https://github.com/WayfireWM/wayfire')
@@ -18,25 +19,27 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/wayfire"
-
-# Git, no tags available
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-
+ git tag -l | awk '/^[0-9.]+$/ {print $0} /^v{1}[0-9.]+$/ {print substr($0,2)}'|sort -n|tail -n1
}
build() {
- cd "$srcdir/wayfire/"
- arch-meson \
- -Duse_system_wlroots=enabled \
- -Duse_system_wfconfig=enabled \
- build
- ninja -C build
+ cd "$srcdir/wayfire/"
+ arch-meson \
+ --buildtype=release \
+ -Dxwayland=auto \
+ -Duse_system_wlroots=disabled \
+ -Duse_system_wfconfig=disabled \
+ -Db_lto=true \
+ -Db_pie=true \
+ build
+ ninja -C build
+ sed "/WF_SRC_DIR/d" -i build/config.h
}
package() {
- cd "$srcdir/wayfire"
- DESTDIR="$pkgdir/" ninja -C build install
- install -Dm644 wayfire.desktop $pkgdir/usr/share/wayland-sessions/wayfire.desktop
- cp wayfire.ini $pkgdir/usr/share
+ cd "$srcdir/wayfire"
+ DESTDIR="$pkgdir/" ninja -C build install
+ install -Dm644 wayfire.desktop $pkgdir/usr/share/wayland-sessions/wayfire.desktop
+ cp wayfire.ini $pkgdir/usr/share
}