summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2021-04-22 09:20:29 -0400
committersolaraquarion2021-04-22 09:20:29 -0400
commitdfa5a05602d5df02958c83d2e9555868a7f96696 (patch)
tree5e2ae04ed19500328cd3d3a9dc668646b45bce6a
parentc9acae5a74c3340c4aa582128124f862468158c2 (diff)
downloadaur-dfa5a05602d5df02958c83d2e9555868a7f96696.tar.gz
Fix wayfire and support for wlroots master
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--update_build.patch112
3 files changed, 130 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 487799b4bbea..72f11a9bb9b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wayfire-git
pkgdesc = 3D wayland compositor
- pkgver = 0.4.0.r168.g25d568f
+ pkgver = 0.6.0.r173.gf9683574
pkgrel = 1
url = https://github.com/ammen99/wayfire
arch = x86_64
@@ -14,12 +14,14 @@ pkgbase = wayfire-git
depends = glm
depends = libjpeg
depends = wf-config-git
+ depends = seatd
optdepends = wf-shell-git: GTK3-based panel for the Wayfire compositor
optdepends = wf-sound-control-git: Small utility for the Wayfire compositor to control sound volume
provides = wayfire
conflicts = wayfire
- source = git+https://github.com/ammen99/wayfire
+ source = git+https://github.com/WayfireWM/wayfire
+ source = update_build.patch
sha256sums = SKIP
+ sha256sums = 1f584f9094005da424d761129aa68a98b3daaa4fa2ff4d68edaa2f051bf8e1c7
pkgname = wayfire-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 42b4b3868b31..7283c31dc57d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com0
pkgname=wayfire-git
-pkgver=0.4.0.r168.g25d568f
+pkgver=0.6.0.r173.gf9683574
pkgrel=1
pkgdesc="3D wayland compositor"
arch=('x86_64')
url="https://github.com/ammen99/wayfire"
license=('MIT')
-depends=('wlroots-git' 'cairo' 'glm' 'libjpeg' 'wf-config-git')
+depends=('wlroots-git' 'cairo' 'glm' 'libjpeg' 'wf-config-git' 'seatd')
makedepends=('git' 'meson' 'ninja' 'wayland-protocols')
optdepends=('wf-shell-git: GTK3-based panel for the Wayfire compositor'
'wf-sound-control-git: Small utility for the Wayfire compositor to control sound volume')
@@ -14,12 +14,15 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
options=()
-source=('git+https://github.com/ammen99/wayfire')
-sha256sums=('SKIP')
+source=('git+https://github.com/WayfireWM/wayfire'
+ 'update_build.patch')
+sha256sums=('SKIP'
+ '1f584f9094005da424d761129aa68a98b3daaa4fa2ff4d68edaa2f051bf8e1c7')
prepare() {
- cd "$srcdir/wayfire"
- git submodule update --init --recursive
+ cd "$srcdir/wayfire"
+ patch -Np1 -i ../1152.patch
+
}
pkgver() {
cd "$srcdir/wayfire"
@@ -31,7 +34,10 @@ pkgver() {
build() {
cd "$srcdir/wayfire/"
- arch-meson build
+ arch-meson \
+ -Duse_system_wlroots=enabled \
+ -Duse_system_wfconfig=enabled \
+ build
ninja -C build
}
diff --git a/update_build.patch b/update_build.patch
new file mode 100644
index 000000000000..910c33c5079f
--- /dev/null
+++ b/update_build.patch
@@ -0,0 +1,112 @@
+From 9d4fabc0a2d496493ec96a3ef4a9ebc612d7c00f Mon Sep 17 00:00:00 2001
+From: Ilia Bozhinov <ammen99@gmail.com>
+Date: Wed, 21 Apr 2021 11:28:40 +0200
+Subject: [PATCH 1/3] update meson.build and wlroots submodule
+
+---
+ meson.build | 4 ++--
+ src/api/wayfire/nonstd/wlroots-full.hpp | 8 +++-----
+ 3 files changed, 6 insertions(+), 8 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index f0e6ee8e..9177ac5e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -2,7 +2,7 @@ project(
+ 'wayfire',
+ 'c',
+ 'cpp',
+- version: '0.7.0',
++ version: '0.7.999',
+ license: 'MIT',
+ meson_version: '>=0.53.0',
+ default_options: [
+@@ -28,7 +28,7 @@ libinput = dependency('libinput', version: '>=1.7.0')
+ pixman = dependency('pixman-1')
+ threads = dependency('threads')
+ xkbcommon = dependency('xkbcommon')
+-wlroots = dependency('wlroots', version: ['>=0.12.0', '<0.13.0'], required: get_option('use_system_wlroots'))
++wlroots = dependency('wlroots', version: ['>=0.14.0', '<0.15.0'], required: get_option('use_system_wlroots'))
+ wfconfig = dependency('wf-config', version: ['>=0.7.0', '<0.8.0'], required: get_option('use_system_wfconfig'))
+
+ use_system_wlroots = not get_option('use_system_wlroots').disabled() and wlroots.found()
+diff --git a/src/api/wayfire/nonstd/wlroots-full.hpp b/src/api/wayfire/nonstd/wlroots-full.hpp
+index 609a56c2..5d2d1872 100644
+--- a/src/api/wayfire/nonstd/wlroots-full.hpp
++++ b/src/api/wayfire/nonstd/wlroots-full.hpp
+@@ -69,11 +69,9 @@ extern "C"
+ #undef class
+ #endif
+
+-#if WLR_HAS_XDG_FOREIGN
+- #include <wlr/types/wlr_xdg_foreign_registry.h>
+- #include <wlr/types/wlr_xdg_foreign_v1.h>
+- #include <wlr/types/wlr_xdg_foreign_v2.h>
+-#endif
++#include <wlr/types/wlr_xdg_foreign_registry.h>
++#include <wlr/types/wlr_xdg_foreign_v1.h>
++#include <wlr/types/wlr_xdg_foreign_v2.h>
+
+ // Backends
+ #include <wlr/config.h>
+
+
+From 1edaded7fd622fdcd87dafc5025387731698be78 Mon Sep 17 00:00:00 2001
+From: Ilia Bozhinov <ammen99@gmail.com>
+Date: Wed, 21 Apr 2021 11:35:56 +0200
+Subject: [PATCH 2/3] ci: add libseat dependency
+
+---
+ .github/workflows/ci.yaml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
+index 7ac574d3..f83bd57d 100644
+--- a/.github/workflows/ci.yaml
++++ b/.github/workflows/ci.yaml
+@@ -7,7 +7,7 @@ jobs:
+ runs-on: ubuntu-latest
+ container: alpine:edge
+ steps:
+- - run: apk --no-cache add git gcc g++ binutils pkgconf meson ninja musl-dev wayland-dev wayland-protocols libinput-dev libevdev-dev libxkbcommon-dev pixman-dev glm-dev libdrm-dev mesa-dev cairo-dev eudev-dev libxml2-dev libexecinfo-dev
++ - run: apk --no-cache add git gcc g++ binutils pkgconf meson ninja musl-dev wayland-dev wayland-protocols libinput-dev libevdev-dev libxkbcommon-dev pixman-dev glm-dev libdrm-dev mesa-dev cairo-dev eudev-dev libxml2-dev libexecinfo-dev libseat-dev
+ - uses: actions/checkout@v1
+ - run: git submodule sync --recursive && git submodule update --init --force --recursive
+ - run: meson build
+@@ -19,7 +19,7 @@ jobs:
+ steps:
+ - run: (pacman-key --keyserver hkp://keys.gnupg.net --recv-key EA50C866329648EE || pacman-key --keyserver hkp://pool.sks-keyservers.net --recv-key EA50C866329648EE || pacman-key --keyserver hkp://pgp.mit.edu --recv-key EA50C866329648EE) && echo "[andontie-aur]" >> /etc/pacman.conf && echo "Server = https://aur.andontie.net/\$arch" >> /etc/pacman.conf && echo "SigLevel = Never" >> /etc/pacman.conf
+ - run: pacman --noconfirm --noprogressbar -Syyu
+- - run: pacman --noconfirm --noprogressbar -Sy git clang lld libc++ pkgconf meson ninja wayland wayland-protocols libinput libxkbcommon pixman glm libdrm libglvnd cairo
++ - run: pacman --noconfirm --noprogressbar -Sy git clang lld libc++ pkgconf meson ninja wayland wayland-protocols libinput libxkbcommon pixman glm libdrm libglvnd cairo seatd
+ - uses: actions/checkout@v1
+ - run: git submodule sync --recursive && git submodule update --init --force --recursive
+ - run: env CC=clang CXX=clang++ CXXFLAGS="-stdlib=libc++" LDFLAGS="-fuse-ld=lld -stdlib=libc++" meson build
+
+From 84d43eead48e1ca118898f0f92da026e6996089f Mon Sep 17 00:00:00 2001
+From: Ilia Bozhinov <ammen99@gmail.com>
+Date: Wed, 21 Apr 2021 12:13:35 +0200
+Subject: [PATCH 3/3] add yay instead of andontie
+
+---
+ .github/workflows/ci.yaml | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
+index f83bd57d..12269915 100644
+--- a/.github/workflows/ci.yaml
++++ b/.github/workflows/ci.yaml
+@@ -17,9 +17,11 @@ jobs:
+ runs-on: ubuntu-latest
+ container: archlinux:latest
+ steps:
+- - run: (pacman-key --keyserver hkp://keys.gnupg.net --recv-key EA50C866329648EE || pacman-key --keyserver hkp://pool.sks-keyservers.net --recv-key EA50C866329648EE || pacman-key --keyserver hkp://pgp.mit.edu --recv-key EA50C866329648EE) && echo "[andontie-aur]" >> /etc/pacman.conf && echo "Server = https://aur.andontie.net/\$arch" >> /etc/pacman.conf && echo "SigLevel = Never" >> /etc/pacman.conf
+ - run: pacman --noconfirm --noprogressbar -Syyu
+- - run: pacman --noconfirm --noprogressbar -Sy git clang lld libc++ pkgconf meson ninja wayland wayland-protocols libinput libxkbcommon pixman glm libdrm libglvnd cairo seatd
++ - run: pacman --noconfirm --noprogressbar -Sy git go
++ - run: git clone https://aur.archlinux.org/yay.git
++ - run: cd yay && makepkg -si && cd ..
++ - run: yay --noconfirm --noprogressbar -Sy git clang lld libc++ pkgconf meson ninja wayland wayland-protocols libinput libxkbcommon pixman glm libdrm libglvnd cairo seatd
+ - uses: actions/checkout@v1
+ - run: git submodule sync --recursive && git submodule update --init --force --recursive
+ - run: env CC=clang CXX=clang++ CXXFLAGS="-stdlib=libc++" LDFLAGS="-fuse-ld=lld -stdlib=libc++" meson build