summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-08-06 00:00:22 +0300
committerAdrian Perez de Castro2020-08-06 00:00:22 +0300
commit585cc1f27bf179265abe9a3092bf7d33b12672fe (patch)
tree711a402e7936daaa4eaf97ef2a36d54e16a65f8d
downloadaur-585cc1f27bf179265abe9a3092bf7d33b12672fe.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a07359e7706b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wayfire-plugins-extra
+ pkgdesc = Additional plugins for Wayfire
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://wayfire.org
+ arch = x86_64
+ license = custom:MIT
+ depends = wayfire>=0.5
+ depends = cairo
+ depends = glibmm
+ conflicts = wayfire-plugins-extra-git
+ source = wayfire-plugins-extra-0.5.0.tar.gz::https://github.com/WayfireWM/wayfire-plugins-extra/archive/v0.5.0.tar.gz
+ sha256sums = 64c56ffa66df26a7cbee1af41c34ae123abe8252deeaf02687237688a8281a9e
+
+pkgname = wayfire-plugins-extra
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b83fbff8d244
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+pkgname=wayfire-plugins-extra
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='Additional plugins for Wayfire'
+url=https://wayfire.org
+arch=(x86_64)
+license=(custom:MIT)
+conflicts=("${pkgname}-git")
+depends=('wayfire>=0.5' cairo glibmm)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/WayfireWM/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=(64c56ffa66df26a7cbee1af41c34ae123abe8252deeaf02687237688a8281a9e)
+
+build () {
+ rm -rf build
+ arch-meson "${pkgname}-${pkgver}" build
+ ninja -C build
+}
+
+check () {
+ meson test -C build
+}
+
+package () {
+ DESTDIR="${pkgdir}" ninja -C build install
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}