summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2019-10-28 10:52:07 +0530
committerlibrewish2019-10-28 10:52:07 +0530
commit62cd8ce3dae2a8aa429a5a601139862fd9e46674 (patch)
tree33f1ff4453eedd78e8a1f4431ec70c37e9a864a8
parent2971bb949ee82623206905c31421b9f944bfbe5d (diff)
downloadaur-62cd8ce3dae2a8aa429a5a601139862fd9e46674.tar.gz
add iio-sensor-proxy as dep
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--wayfire-plugins-extra.install28
3 files changed, 32 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d22403529e56..d9da4123f725 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = wayfire-plugins-extra-git
pkgver = r8.5c9aa89
pkgrel = 1
url = https://github.com/WayfireWM/wayfire-plugins-extra
+ install = wayfire-plugins-extra.install
arch = any
license = MIT
makedepends = git
@@ -18,6 +19,7 @@ pkgbase = wayfire-plugins-extra-git
depends = boost
depends = gtkmm3
depends = libxkbcommon
+ depends = iio-sensor-proxy
optdepends = wcm: GTK3-based configuration tool for the Wayfire compositor
provides = wayfire-plugins-extra-git
provides = wayfire-plugins-extra
diff --git a/PKGBUILD b/PKGBUILD
index ba89ff1402eb..c6b7388d2716 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc="3D wayland compositor extra plugins"
arch=('any')
url="https://github.com/WayfireWM/wayfire-plugins-extra"
license=('MIT')
-depends=('wayfire' 'glibmm' 'wlroots' 'wf-config' 'wayland-protocols' 'boost' 'gtkmm3' 'libxkbcommon')
+depends=('wayfire' 'glibmm' 'wlroots' 'wf-config' 'wayland-protocols' 'boost' 'gtkmm3' 'libxkbcommon' 'iio-sensor-proxy')
makedepends=('git' 'meson' 'ninja' 'wayland-protocols' 'extra-cmake-modules')
optdepends=('wcm: GTK3-based configuration tool for the Wayfire compositor')
provides=("${pkgname}" "wayfire-plugins-extra")
@@ -14,7 +14,7 @@ replaces=()
options=()
source=('git+https://github.com/WayfireWM/wayfire-plugins-extra')
sha256sums=('SKIP')
-
+install=wayfire-plugins-extra.install
prepare() {
cd "$srcdir/wayfire-plugins-extra"
git submodule update --init --recursive
diff --git a/wayfire-plugins-extra.install b/wayfire-plugins-extra.install
new file mode 100644
index 000000000000..df671e6f33c7
--- /dev/null
+++ b/wayfire-plugins-extra.install
@@ -0,0 +1,28 @@
+msg() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ GREEN="${BOLD}\e[1;32m"
+ local mesg=$1; shift
+ printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}" "$@" >&2
+}
+
+post_upgrade() {
+ msg "Attempting to enable iio-sensor-proxy service..."
+ systemctl is-active iio-sensor-proxy >/dev/null || systemctl enable iio-sensor-proxy
+ echo ""
+ msg "services enabled."
+ echo ""
+}
+
+post_install() {
+ msg "Attempting to enable iio-sensor-proxy service..."
+ systemctl is-active iio-sensor-proxy >/dev/null || systemctl enable iio-sensor-proxy
+ echo ""
+ msg "services enabled."
+ echo ""
+ msg "services should now be enabled."
+ msg "Reboot your system, so changes will take effect.."
+ echo ""
+}
+
+# vim: ts=2 sw=2 et: