summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2024-03-16 20:12:59 +0100
committerDan Johansen2024-03-16 20:12:59 +0100
commit971b512a95179f708a24ed989bb5886f5e795877 (patch)
tree1c36d2812a5589a6deabb61a27c7f93f621bfb12
parent8b053e02c0c7c5e36a48f9563c52206ac498eb80 (diff)
downloadaur-wayfire-plugins-qtshell.tar.gz
fix compilation against wlroots 0.17
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40b2f2d712e6..0581b17b74d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wayfire-plugins-qtshell
pkgdesc = Implementation of qt-shell protocol for Wayfire in the form of wayfire plugin
pkgver = 0.8.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/wayfireplugins/qt-shell
arch = x86_64
arch = aarch64
@@ -11,6 +11,8 @@ pkgbase = wayfire-plugins-qtshell
makedepends = glm
depends = wayfire
source = https://gitlab.com/wayfireplugins/qt-shell/-/archive/v0.8.0.1/qt-shell-v0.8.0.1.tar.gz
+ source = https://gitlab.com/wayfireplugins/qt-shell/-/commit/3a6fb99f64f20b31bce3494a487fd46d9e23bb47.patch
md5sums = 7222f3368874f06e54b622e503764c21
+ md5sums = 1a5c40f30489028abb7c4bed9f80768f
pkgname = wayfire-plugins-qtshell
diff --git a/PKGBUILD b/PKGBUILD
index 47da46c14dd3..b1824dfe61a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,26 @@
_pkgname=qt-shell
pkgname=wayfire-plugins-qtshell
pkgver=0.8.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Implementation of qt-shell protocol for Wayfire in the form of wayfire plugin"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/wayfireplugins/${_pkgname}"
license=('MIT')
depends=('wayfire')
makedepends=('meson' 'ninja' 'glm')
-source=("https://gitlab.com/wayfireplugins/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
-md5sums=('7222f3368874f06e54b622e503764c21')
+source=("https://gitlab.com/wayfireplugins/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz"
+ "https://gitlab.com/wayfireplugins/qt-shell/-/commit/3a6fb99f64f20b31bce3494a487fd46d9e23bb47.patch")
+md5sums=('7222f3368874f06e54b622e503764c21'
+ '1a5c40f30489028abb7c4bed9f80768f')
+
+prepare() {
+ cd "${_pkgname}-v${pkgver}"
+ patch -Np1 -i ../3a6fb99f64f20b31bce3494a487fd46d9e23bb47.patch #fix compilation against wlroots 0.17
+}
build() {
cd "${_pkgname}-v${pkgver}"
- PKG_CONFIG_PATH=/usr/lib/wlroots0.16/pkgconfig meson setup .build --prefix=/usr --buildtype=release
+ meson setup .build --prefix=/usr --buildtype=release
ninja -C .build
}