summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2023-10-09 17:01:57 +0200
committerDan Johansen2023-10-09 17:01:57 +0200
commitb16582e15e495a3c23fc17608cacce8e896e9ebb (patch)
treebd8680367ff118243e9bf0638148e61dcb22a8b6
downloadaur-b16582e15e495a3c23fc17608cacce8e896e9ebb.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afb3fe771b2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wayfire-plugins-qtshell
+ pkgdesc = Implementation of qt-shell protocol for Wayfire in the form of wayfire plugin
+ pkgver = 0.8.0.1
+ pkgrel = 1
+ url = https://gitlab.com/wayfireplugins/qt-shell
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = meson
+ makedepends = ninja
+ makedepends = glm
+ depends = wayfire
+ source = https://gitlab.com/wayfireplugins/qt-shell/-/archive/v0.8.0.1/qt-shell-v0.8.0.1.tar.gz
+ md5sums = 7222f3368874f06e54b622e503764c21
+
+pkgname = wayfire-plugins-qtshell
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d42e43b10d0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+_pkgname=qt-shell
+pkgname=wayfire-plugins-qtshell
+pkgver=0.8.0.1
+pkgrel=1
+pkgdesc="Implementation of qt-shell protocol for Wayfire in the form of wayfire plugin"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/wayfireplugins/${_pkgname}"
+license=('MIT')
+depends=('wayfire')
+makedepends=('meson' 'ninja' 'glm')
+source=("https://gitlab.com/wayfireplugins/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
+md5sums=('7222f3368874f06e54b622e503764c21')
+
+build() {
+ cd "${_pkgname}-v${pkgver}"
+ meson .build --prefix=/usr --buildtype=release
+ ninja -C .build
+}
+
+package() {
+ cd "${_pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C .build install
+}
+