summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2023-12-06 17:04:06 +0100
committerDan Johansen2023-12-06 17:04:06 +0100
commit4b843250a9be40004067d27197e794ab6d0fb435 (patch)
treecdfb93a1e7c22641d0b6e84e69351f466f8efaff
downloadaur-4b843250a9be40004067d27197e794ab6d0fb435.tar.gz
initial commit, version 0.8.0
Signed-off-by: Dan Johansen <strit@strits.dk>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bafb44e6d53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wayfire-plugins-toplevel-manager
+ pkgdesc = A general window management protocol, and its implementation for Wayfire in the form of wayfire plugin
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://gitlab.com/wayfireplugins/windowmanager
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = meson
+ makedepends = ninja
+ makedepends = glm
+ depends = wayfire
+ depends = wlroots
+ depends = wayland
+ source = https://gitlab.com/wayfireplugins/windowmanager/-/archive/v0.8.0/windowmanager-v0.8.0.tar.gz
+ md5sums = bee49efa44c7d653c75d891dca1ac25a
+
+pkgname = wayfire-plugins-toplevel-manager
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5268b28f90f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dan Johansen <strit@strits.dk>
+
+_pkgname=windowmanager
+pkgname=wayfire-plugins-toplevel-manager
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="A general window management protocol, and its implementation for Wayfire in the form of wayfire plugin"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/wayfireplugins/${_pkgname}"
+license=('MIT')
+depends=('wayfire' 'wlroots' 'wayland')
+makedepends=('meson' 'ninja' 'glm')
+source=("https://gitlab.com/wayfireplugins/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
+md5sums=('bee49efa44c7d653c75d891dca1ac25a')
+
+build() {
+ cd "${_pkgname}-v${pkgver}"
+ PKG_CONFIG_PATH=/usr/lib/wlroots0.16/pkgconfig meson setup .build --prefix=/usr --buildtype=release
+ ninja -C .build
+}
+
+package() {
+ cd "${_pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C .build install
+}
+