summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-06-05 14:50:08 +0000
committerDaniel Bermond2020-06-05 14:50:08 +0000
commite787a386c30f4942be06efb4fcfeb23588729dca (patch)
tree0bc392cd16712db5147fd66be5271df7ce4bf497
parentaf05d1b8d4806aae5e5436c37535dd40826f302a (diff)
downloadaur-wayland-git.tar.gz
Change build system to meson. General improvements.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD49
2 files changed, 20 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6740fc42a832..4f547fe91e13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = wayland-git
- pkgdesc = A computer display server protocol
- pkgver = 1.17.0.r6.gb77cf86
+ pkgdesc = A computer display server protocol (git version)
+ pkgver = 1.18.0.r18.gef611a80
pkgrel = 1
url = https://wayland.freedesktop.org/
arch = x86_64
license = MIT
makedepends = git
+ makedepends = meson
+ makedepends = ninja
makedepends = libxslt
makedepends = doxygen
makedepends = xmlto
@@ -19,13 +21,13 @@ pkgbase = wayland-git
sha256sums = SKIP
pkgname = wayland-git
- provides = wayland=1.17.0.r6.gb77cf86
+ provides = wayland=1.18.0.r18.gef611a80
conflicts = wayland
pkgname = wayland-docs-git
- pkgdesc = A computer display server protocol (documentation)
+ pkgdesc = A computer display server protocol (git version) (documentation)
arch = any
depends =
- provides = wayland-docs=1.17.0.r6.gb77cf86
+ provides = wayland-docs=1.18.0.r18.gef611a80
conflicts = wayland-docs
diff --git a/PKGBUILD b/PKGBUILD
index 675aeb520ffc..5c955d9b5e69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,40 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
# Contributor: Joel Teichroeb <joel@teichroeb.net>
# Contributor: Scimmia
pkgbase=wayland-git
pkgname=('wayland-git' 'wayland-docs-git')
-pkgver=1.17.0.r6.gb77cf86
+pkgver=1.18.0.r18.gef611a80
pkgrel=1
-pkgdesc='A computer display server protocol'
+pkgdesc='A computer display server protocol (git version)'
arch=('x86_64')
url='https://wayland.freedesktop.org/'
license=('MIT')
depends=('glibc' 'libffi' 'expat' 'libxml2')
-makedepends=('git' 'libxslt' 'doxygen' 'xmlto' 'graphviz' 'docbook-xsl')
+makedepends=('git' 'meson' 'ninja' 'libxslt' 'doxygen' 'xmlto' 'graphviz' 'docbook-xsl')
source=('git+https://gitlab.freedesktop.org/wayland/wayland.git')
sha256sums=('SKIP')
-prepare() {
- mkdir -p docs/share
-}
-
pkgver() {
- cd wayland
-
- # git, tags available
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C wayland describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd wayland
-
- ./autogen.sh \
- --prefix='/usr' \
- --disable-static
-
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ meson build wayland --buildtype='release' --prefix='/usr'
}
check() {
- cd wayland
-
- make check
+ ninja -C build test
}
package_wayland-git() {
provides=("wayland=${pkgver}")
conflicts=('wayland')
- cd wayland
-
- make DESTDIR="$pkgdir" install
-
- mv "$pkgdir"/usr/share/{doc,man} "${srcdir}/docs/share"
-
- install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ DESTDIR="$pkgdir" ninja -C build install
+ mkdir -p docs/share
+ mv "${pkgdir}/usr/share/"{doc,man} docs/share
+ install -D -m644 wayland/COPYING "$p{kgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_wayland-docs-git() {
@@ -64,9 +44,6 @@ package_wayland-docs-git() {
provides=("wayland-docs=${pkgver}")
conflicts=('wayland-docs')
- cd wayland
-
- mv "${srcdir}/docs" "${pkgdir}/usr"
-
- install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mv docs "${pkgdir}/usr"
+ install -D -m644 wayland/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}