summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-04-19 16:26:59 +0000
committerDaniel Bermond2019-04-19 16:26:59 +0000
commitaf05d1b8d4806aae5e5436c37535dd40826f302a (patch)
treedbd3cceaa89660785daf3684da75db85578d1a77
parentcc5123e23b188ccfbfc7fc3db868bd7dbea5c91d (diff)
downloadaur-af05d1b8d4806aae5e5436c37535dd40826f302a.tar.gz
Update dependencies. Change pkgver() method. Cosmetic changes.
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD84
2 files changed, 78 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e39dd412d71..6740fc42a832 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,31 @@
-# Generated by mksrcinfo v8
-# Wed Mar 8 17:18:52 UTC 2017
pkgbase = wayland-git
- pkgdesc = A computer display server protocol.
- pkgver = 1.13.90.2010.9b78be6
+ pkgdesc = A computer display server protocol
+ pkgver = 1.17.0.r6.gb77cf86
pkgrel = 1
- url = http://wayland.freedesktop.org
- arch = i686
+ url = https://wayland.freedesktop.org/
arch = x86_64
license = MIT
makedepends = git
+ makedepends = libxslt
+ makedepends = doxygen
+ makedepends = xmlto
+ makedepends = graphviz
+ makedepends = docbook-xsl
+ depends = glibc
depends = libffi
- depends = libxml2
depends = expat
- provides = wayland=1.13.90.2010.9b78be6
- conflicts = wayland
- source = git://anongit.freedesktop.org/wayland/wayland
- sha1sums = SKIP
+ depends = libxml2
+ source = git+https://gitlab.freedesktop.org/wayland/wayland.git
+ sha256sums = SKIP
pkgname = wayland-git
+ provides = wayland=1.17.0.r6.gb77cf86
+ conflicts = wayland
+
+pkgname = wayland-docs-git
+ pkgdesc = A computer display server protocol (documentation)
+ arch = any
+ depends =
+ provides = wayland-docs=1.17.0.r6.gb77cf86
+ conflicts = wayland-docs
diff --git a/PKGBUILD b/PKGBUILD
index 71533854358f..675aeb520ffc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,72 @@
-# Maintainer: Joel Teichroeb <joel@teichroeb.net>
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Contributor: Joel Teichroeb <joel@teichroeb.net>
# Contributor: Scimmia
-pkgname=wayland-git
-pkgver=1.13.90.2010.9b78be6
+pkgbase=wayland-git
+pkgname=('wayland-git' 'wayland-docs-git')
+pkgver=1.17.0.r6.gb77cf86
pkgrel=1
-pkgdesc='A computer display server protocol.'
-arch=(i686 x86_64)
-url='http://wayland.freedesktop.org'
-provides=("wayland=${pkgver}")
+pkgdesc='A computer display server protocol'
+arch=('x86_64')
+url='https://wayland.freedesktop.org/'
license=('MIT')
-depends=('libffi' 'libxml2' 'expat')
-makedepends=('git')
-conflicts=('wayland')
-source=(git://anongit.freedesktop.org/wayland/wayland)
-sha1sums=('SKIP')
+depends=('glibc' 'libffi' 'expat' 'libxml2')
+makedepends=('git' 'libxslt' 'doxygen' 'xmlto' 'graphviz' 'docbook-xsl')
+source=('git+https://gitlab.freedesktop.org/wayland/wayland.git')
+sha256sums=('SKIP')
-pkgver() {
- cd wayland
-
- for i in major_version minor_version micro_version; do
- local _$i=$(grep -m 1 $i configure.ac | sed 's/m4//' | grep -o "[[:digit:]]*")
- done
-
- echo $_major_version.$_minor_version.$_micro_version.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+prepare() {
+ mkdir -p docs/share
}
+pkgver() {
+ cd wayland
+
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
build() {
cd wayland
-
- ./autogen.sh --prefix=/usr \
- --disable-documentation \
- --disable-static
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --disable-static
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
make
}
-package() {
+check() {
+ cd wayland
+
+ make check
+}
+
+package_wayland-git() {
+ provides=("wayland=${pkgver}")
+ conflicts=('wayland')
+
+ cd wayland
+
+ make DESTDIR="$pkgdir" install
+
+ mv "$pkgdir"/usr/share/{doc,man} "${srcdir}/docs/share"
+
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_wayland-docs-git() {
+ pkgdesc+=' (documentation)'
+ arch=('any')
+ depends=()
+ provides=("wayland-docs=${pkgver}")
+ conflicts=('wayland-docs')
+
cd wayland
- make DESTDIR="${pkgdir}" install
- install -Dm 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+ mv "${srcdir}/docs" "${pkgdir}/usr"
+
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}