summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Klokkhammer Helsing2018-06-29 10:56:05 +0200
committerJohan Klokkhammer Helsing2018-06-29 10:58:30 +0200
commit15b46930e05e6ae34c04efe69c6d19d209b0acd2 (patch)
treec42b51e110444bb975f61e5cc8faaa7d3485c45c
downloadaur-15b46930e05e6ae34c04efe69c6d19d209b0acd2.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a3b150099cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wayland-log-reader-git
+ pkgdesc = Application for navigating and making sense of WAYLAND_DEBUG log output
+ pkgver = 20180629.17.c2430c9
+ pkgrel = 1
+ url = https://github.com/johanhelsing/wayland-log-reader
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ makedepends = qbs
+ depends = qt5-base
+ depends = qt5-quickcontrols2
+ source = wayland-log-reader-git::git://github.com/johanhelsing/wayland-log-reader.git#branch=master
+ md5sums = SKIP
+
+pkgname = wayland-log-reader-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e62cc2ffdf7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Johan Klokkhammer Helsing <johanhelsing@gmail.com>
+
+pkgname=wayland-log-reader-git
+pkgver=0.20180629.17.c2430c9
+pkgrel=1
+pkgdesc="Application for navigating and making sense of WAYLAND_DEBUG log output"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://github.com/johanhelsing/wayland-log-reader'
+license=('GPL3')
+depends=('qt5-base' 'qt5-quickcontrols2')
+makedepends=('git' 'qbs')
+
+_gitroot="git://github.com/johanhelsing/wayland-log-reader.git"
+_gitbranch=master
+_gitname=$pkgname
+source=("${_gitname}::${_gitroot}#branch=${_gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo "0.$(git log -1 --format="%cd" --date=short | tr -d '-').$(git rev-list --count HEAD).$(git log -1 --format="%h")"
+}
+
+build() {
+ cd ${srcdir}/${_gitname}
+ qbs setup-toolchains --type gcc /usr/bin/g++ gcc
+ qbs setup-qt /usr/bin/qmake-qt5 qt5
+ qbs config profiles.qt5.baseProfile gcc
+ qbs build --no-install -d build profile:qt5
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ qbs install -d build --no-build --install-root $pkgdir -v profile:qt5
+}