summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoronokatio2020-05-13 01:33:01 +0900
committeronokatio2020-05-13 01:33:01 +0900
commit7aeab7960732c45f394f03d795190eaf2b6802aa (patch)
treed45d2bf2f7b3205238d3e040a9194abcb64bf132
downloadaur-7aeab7960732c45f394f03d795190eaf2b6802aa.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..078cfd5ba40e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wayland-screenshot-git
+ pkgver = 1.0.1.r0.06a4114
+ pkgrel = 1
+ url = https://github.com/onokatio/wayland-screenshot
+ arch = any
+ license = GPL
+ makedepends = git
+ provides = wayland-screenshot
+ conflicts = wayland-screenshot
+ source = git+https://github.com/onokatio/wayland-screenshot
+ md5sums = SKIP
+
+pkgname = wayland-screenshot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e828da1a395b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=wayland-screenshot-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=1.0.1.r0.06a4114
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://github.com/onokatio/wayland-screenshot"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/onokatio/wayland-screenshot')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, tags available
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D -m755 ./wayland-screenshot ${pkgdir}/usr/bin/wayland-screenshot
+ install -D -m644 ./wayland-screenshot.desktop ${pkgdir}/usr/share/applications/wayland-screenshot.desktop
+}