summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet2017-06-09 08:04:19 +0200
committerRuben De Smet2017-06-09 08:04:19 +0200
commit5dbf066832e15a141374c48c5fab578289263ce4 (patch)
tree4cd01362bcc818a29e7d0906c2dd1d64843258a3
parent59b486a90df641bcea708a6c4b1a4c07c8347bf8 (diff)
downloadaur-5dbf066832e15a141374c48c5fab578289263ce4.tar.gz
Build system changed to ninja
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d6a4e0a8223..7d01baad2c49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
# Generated by mksrcinfo v8
-# Sat Mar 25 15:47:04 UTC 2017
+# Fri Jun 9 06:04:06 UTC 2017
pkgbase = wayland-wall-git
pkgdesc = A collection of protocols, called bricks, to create a complete desktop experience for Wayland.
- pkgver = r47.68eab6f
+ pkgver = r49.39400ea
pkgrel = 1
url = https://github.com/wayland-wall/wayland-wall
arch = i686
arch = x86_64
license = MIT
makedepends = git
+ makedepends = meson
+ makedepends = ninja
depends = gdk-pixbuf2
depends = pango
depends = wayland-protocols
diff --git a/PKGBUILD b/PKGBUILD
index 34e6327b659b..d297925bdb06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Ruben De Smet <me at rubdos dot be>
+# Contributor: btschaegg
pkgname=wayland-wall-git
_gitname=wayland-wall
-pkgver=r47.68eab6f
+pkgver=r49.39400ea
pkgrel=1
pkgdesc="A collection of protocols, called bricks, to create a complete desktop experience for Wayland."
arch=('i686' 'x86_64')
url="https://github.com/wayland-wall/wayland-wall"
license=('MIT')
depends=('gdk-pixbuf2' 'pango' 'wayland-protocols')
-makedepends=('git')
+makedepends=('git' 'meson' 'ninja')
provides=('wayland-wall' 'wayland-wall-git')
conflicts=('wayland-wall')
source=("git+https://github.com/wayland-wall/wayland-wall.git")
@@ -23,23 +24,24 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
git submodule update --init
- autoreconf --install
- ./configure \
- --prefix=/usr \
- --enable-clients \
- --enable-images \
- --enable-text
+ mkdir -p build
+ meson build \
+ --buildtype=release \
+ -Dprefix=/usr \
+ -Denable-clients=true \
+ -Denable-images=true \
+ -Denable-text=true
}
build() {
cd "$srcdir/$_gitname"
- make
+ ninja -C build
}
package() {
cd "$srcdir/$_gitname"
- make install install-man DESTDIR="$pkgdir"
+ DESTDIR="$pkgdir" ninja -C build install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/wayland-wall-git/COPYING"
}