summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Chr. Brause2017-09-01 16:35:51 +0200
committerNils Chr. Brause2017-09-01 16:41:38 +0200
commit11654ef3194b1d67ba67373d1448dd9f7f93ebc9 (patch)
treec1740c6d84cfd01d2035f4dbf9aed829bc3a90ef
downloadaur-11654ef3194b1d67ba67373d1448dd9f7f93ebc9.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6079e937a2c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = waylandpp-git
+ pkgdesc = Wayland C++ bindings
+ pkgver = 176
+ pkgrel = 1
+ url = https://github.com/NilsBrause/waylandpp
+ arch = i686
+ arch = x86_64
+ arch = armv5
+ arch = armv6
+ arch = armv7
+ arch = armv8
+ makedepends = scons
+ depends = wayland
+ conflicts = waylandpp
+ source = waylandpp-git::git+https://github.com/NilsBrause/waylandpp.git
+ md5sums = SKIP
+
+pkgname = waylandpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e036176b99fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nils Christopher Brause <nilschrbrause@googlemail.com>
+pkgname=waylandpp-git
+pkgver=176
+pkgrel=1
+pkgdesc='Wayland C++ bindings'
+arch=('i686' 'x86_64' 'armv5' 'armv6' 'armv7' 'armv8')
+url='https://github.com/NilsBrause/waylandpp'
+licanse=('MIT' 'GPL3')
+depends=(wayland)
+conflicts=(waylandpp)
+makedepends=(scons)
+source=("${pkgname}::git+https://github.com/NilsBrause/waylandpp.git")
+md5sums=('SKIP')
+
+pkgver()
+{
+ cd $pkgname
+ git log --pretty=oneline | wc -l
+}
+
+build()
+{
+ cd $pkgname
+ scons
+}
+
+package()
+{
+ cd $pkgname
+ ROOT="$pkgdir" PREFIX="/usr" scons install
+}
+
+# Local Variables:
+# mode: shell-script
+# End: