summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Christopher Brause2017-11-06 13:14:32 +0100
committerNils Christopher Brause2017-11-06 13:14:32 +0100
commit74338dbaf916623f78fb5fc4b51fd428d294ea0d (patch)
tree52f5b898ff0266ccf9ba5709ec57bf6c59494b64
parenta734a00d8920640dfbf9b1f7ea53ff67a8851b76 (diff)
downloadaur-74338dbaf916623f78fb5fc4b51fd428d294ea0d.tar.gz
Switch to CMake.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3adf43b2648..437a4959b65b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waylandpp-git
pkgdesc = Wayland C++ bindings
- pkgver = 189
+ pkgver = 210
pkgrel = 1
url = https://github.com/NilsBrause/waylandpp
arch = i686
@@ -9,7 +9,7 @@ pkgbase = waylandpp-git
arch = armv6
arch = armv7
arch = armv8
- makedepends = scons
+ makedepends = cmake
depends = wayland
provides = waylandpp
conflicts = waylandpp
diff --git a/PKGBUILD b/PKGBUILD
index 1da5fef8df83..0c2c98047443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nils Christopher Brause <nilschrbrause@googlemail.com>
pkgname=waylandpp-git
-pkgver=189
+pkgver=210
pkgrel=1
pkgdesc='Wayland C++ bindings'
arch=('i686' 'x86_64' 'armv5' 'armv6' 'armv7' 'armv8')
@@ -9,7 +9,7 @@ licanse=('MIT' 'GPL3')
depends=(wayland)
provides=(waylandpp)
conflicts=(waylandpp)
-makedepends=(scons)
+makedepends=(cmake)
source=("${pkgname}::git+https://github.com/NilsBrause/waylandpp.git")
md5sums=('SKIP')
@@ -22,13 +22,20 @@ pkgver()
build()
{
cd $pkgname
- scons
+ rm -r build
+ mkdir build
+ cd build
+ # lib64 is a symlink to lib on archlinux.
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_INSTALL_LIBDIR="lib" ..
+ make
}
package()
{
- cd $pkgname
- ROOT="$pkgdir" PREFIX="/usr" scons install
+ cd $pkgname/build
+ DESTDIR="$pkgdir" make install
+ cd ..
+ rm -r build
}
# Local Variables: