summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsaac Freund2020-03-19 02:44:22 +0100
committerIsaac Freund2020-03-19 02:44:22 +0100
commit4fdd96b052454b353919d723d47b1bd03f4fd5c9 (patch)
tree3afdae36b375fb808518d22e59f8918c59d6932e
parent503a86ec2b0b3355bf698d41cc434b4d99e0a9af (diff)
downloadaur-4fdd96b052454b353919d723d47b1bd03f4fd5c9.tar.gz
upgpkg: waylock 0.2.0-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d00e344f2811..cf3b53e28fe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waylock
pkgdesc = A simple screenlocker for wayland compositors.
- pkgver = 0.1.1
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/ifreund/waylock
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = waylock
makedepends = rust
depends = cairo
depends = wayland
- source = waylock-0.1.1.tar.gz::https://github.com/ifreund/waylock/archive/v0.1.1.tar.gz
- sha256sums = eff8442c2a00e879b39347e7d68a030b2dcd999316a92e50768daf822dc90a90
+ source = waylock-0.2.0.tar.gz::https://github.com/ifreund/waylock/archive/v0.2.0.tar.gz
+ sha256sums = 5f8b0a116bfc90b4dc5574d13bc9e09305dc808ad9a1d0776093ea857793ce52
pkgname = waylock
diff --git a/PKGBUILD b/PKGBUILD
index 3ed85aa532d9..d9f2a281450a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ifreund <ifreund@ifreund.xyz>
pkgname=waylock
-pkgver=0.1.1
+pkgver=0.2.0
pkgrel=1
pkgdesc='A simple screenlocker for wayland compositors.'
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('MIT')
depends=('cairo' 'wayland')
makedepends=('rust')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('eff8442c2a00e879b39347e7d68a030b2dcd999316a92e50768daf822dc90a90')
+sha256sums=('5f8b0a116bfc90b4dc5574d13bc9e09305dc808ad9a1d0776093ea857793ce52')
build() {
cd "${pkgname}-${pkgver}"
@@ -27,6 +27,7 @@ package() {
install -Dm 755 "target/release/${pkgname}" -t "${pkgdir}/usr/bin"
- install -Dm 644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+ install -Dm 644 "README.md" -t "$pkgdir/usr/share/doc/${pkgname}"
+ install -Dm 644 "waylock.toml" -t "$pkgdir/usr/share/doc/${pkgname}"
install -Dm 644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}