summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kaplan2022-04-29 11:36:06 +0200
committerPeter Kaplan2022-04-29 11:36:06 +0200
commit3c78a31ae7e851b46e0d28b3503b4ae2009ced8c (patch)
treee98950b4bf6132afdfaca94182237c372de9b2ea
parent3da30cf3f910d6a017b921162157d16357acb565 (diff)
downloadaur-3c78a31ae7e851b46e0d28b3503b4ae2009ced8c.tar.gz
Waylock was rewritten in zig by the author.
Reflect those changes in the PKGBUILD.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 38 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42cab9680367..36c1d3597f6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,24 @@
pkgbase = waylock-git
- pkgdesc = Waylock is a simple screenlocker for wayland compositors.
- pkgver = 0.3.3.r2.gd4f4308
+ pkgdesc = A simple screenlocker for Wayland compositors
+ pkgver = 0.3.5.r12.g20be010
pkgrel = 1
url = https://github.com/ifreund/waylock
arch = x86_64
- license = MIT
+ license = ISC
makedepends = git
- makedepends = rust
+ makedepends = zig
+ depends = wayland
+ depends = wayland-protocols
+ depends = libxkbcommon
depends = pam
+ depends = pkgconf
provides = waylock
conflicts = waylock
- source = git+https://github.com/ifreund/waylock.git
+ source = git+https://github.com/ifreund/waylock
+ source = git+https://github.com/ifreund/zig-wayland.git
+ source = git+https://github.com/ifreund/zig-xkbcommon.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = waylock-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 102d1f9aa8bb..734036fe6250 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,45 @@
-# Maintainer: Dasith Gunawardhana <dasith@dg10a.com>
+# Maintainer: Peter Kaplan <peter@pkap.de>
_pkgname=waylock
pkgname=${_pkgname}-git
-pkgver=0.3.3.r2.gd4f4308
+pkgver=0.3.5.r12.g20be010
pkgrel=1
arch=('x86_64')
url="https://github.com/ifreund/waylock"
-pkgdesc="Waylock is a simple screenlocker for wayland compositors."
-license=('MIT')
-depends=('pam')
-makedepends=('git' 'rust')
+pkgdesc="A simple screenlocker for Wayland compositors"
+license=('ISC')
+depends=('wayland' 'wayland-protocols' 'libxkbcommon' 'pam' 'pkgconf')
+makedepends=('git' 'zig')
provides=('waylock')
conflicts=('waylock')
-source=("git+https://github.com/ifreund/waylock.git")
-sha256sums=('SKIP')
+source=(
+ "git+$url"
+ "git+https://github.com/ifreund/zig-wayland.git"
+ "git+https://github.com/ifreund/zig-xkbcommon.git"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd "$_pkgname"
- cargo build --release --locked --all-features --target-dir=target
-}
-
-check(){
- cd "$_pkgname"
- cargo test --release --locked --target-dir=target
+ git submodule init
+ for dep in wayland xkbcommon; do
+ git config "submodule.deps/zig-$dep.url" "$srcdir/zig-$dep"
+ done
+ git submodule update
}
package() {
cd "$_pkgname"
- install -Dm 755 target/release/${_pkgname} -t "${pkgdir}/usr/bin"
- install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
- install -vDm 644 {README.md,waylock.toml} -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ DESTDIR="$pkgdir" zig build -Drelease-safe --prefix "/usr" install
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
}