summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kaplan2022-11-20 10:36:58 +0100
committerPeter Kaplan2022-11-20 10:36:58 +0100
commita39228d97330e84a0c7197ac52fd451bb180fc43 (patch)
treefc0b80482969141d1a765c1eabf2056fef214c4b
parent3c78a31ae7e851b46e0d28b3503b4ae2009ced8c (diff)
downloadaur-a39228d97330e84a0c7197ac52fd451bb180fc43.tar.gz
Add scdoc as makedep and submodule fix
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36c1d3597f6b..0caee551dbce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = waylock-git
pkgdesc = A simple screenlocker for Wayland compositors
- pkgver = 0.3.5.r12.g20be010
+ pkgver = 0.4.0.r9.g7262210
pkgrel = 1
url = https://github.com/ifreund/waylock
arch = x86_64
license = ISC
makedepends = git
makedepends = zig
+ makedepends = scdoc
depends = wayland
depends = wayland-protocols
depends = libxkbcommon
diff --git a/PKGBUILD b/PKGBUILD
index 734036fe6250..fccc9c9f24a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=waylock
pkgname=${_pkgname}-git
-pkgver=0.3.5.r12.g20be010
+pkgver=0.4.0.r9.g7262210
pkgrel=1
arch=('x86_64')
url="https://github.com/ifreund/waylock"
pkgdesc="A simple screenlocker for Wayland compositors"
license=('ISC')
depends=('wayland' 'wayland-protocols' 'libxkbcommon' 'pam' 'pkgconf')
-makedepends=('git' 'zig')
+makedepends=('git' 'zig' 'scdoc')
provides=('waylock')
conflicts=('waylock')
source=(
@@ -32,9 +32,9 @@ prepare() {
cd "$_pkgname"
git submodule init
for dep in wayland xkbcommon; do
- git config "submodule.deps/zig-$dep.url" "$srcdir/zig-$dep"
+ git config "submodule.externals/vendor/zig-${dep}.url" "$srcdir/zig-${dep}"
done
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
package() {