summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2023-10-13 17:34:17 +0200
committerJosip Ponjavic2023-10-13 17:34:17 +0200
commit7f6480f834d19124d25d638922be3bedf7974b3c (patch)
tree04f379a69eb879570a75dc5e04244fab0b6edc01
parent3f2fe2c838de864cbe4cce7db71429b9a1da143c (diff)
downloadaur-7f6480f834d19124d25d638922be3bedf7974b3c.tar.gz
update...
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3a58fd811e9..fdcb1f4b661c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waypaper-git
pkgdesc = GUI wallpaper setter for both Wayland and X11 window managers that works as a frontend for popular backends like swaybg, swww, and feh.
- pkgver = 1.2.r5.ga4e2c6e
+ pkgver = 2.0.r5.g9ff12ac
pkgrel = 1
url = https://github.com/anufrievroman/waypaper
arch = any
@@ -16,6 +16,7 @@ pkgbase = waypaper-git
optdepends = swaybg: the wayland backend that supports only static images
optdepends = swww: the wayland backend that supports animated GIFs
optdepends = feh: the x11 backend that supports static images
+ optdepends = wallutils: another x11 backend
provides = waypaper
conflicts = waypaper
source = waypaper::git+https://github.com/anufrievroman/waypaper.git
diff --git a/PKGBUILD b/PKGBUILD
index 67bb7fba475a..9bb9b3821a0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor:
pkgname=waypaper-git
-pkgver=1.2.r5.ga4e2c6e
+pkgver=2.0.r5.g9ff12ac
pkgrel=1
pkgdesc='GUI wallpaper setter for both Wayland and X11 window managers that works as a frontend for popular backends like swaybg, swww, and feh.'
arch=('any')
@@ -12,10 +12,11 @@ depends=('gtk3' 'gdk-pixbuf2' 'python-gobject')
makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
optdepends=('swaybg: the wayland backend that supports only static images'
'swww: the wayland backend that supports animated GIFs'
- 'feh: the x11 backend that supports static images')
+ 'feh: the x11 backend that supports static images'
+ 'wallutils: another x11 backend')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git+$url.git")
+source=("${pkgname%-*}::git+${url}.git")
sha512sums=('SKIP')
pkgver() {
@@ -31,4 +32,6 @@ build() {
package() {
cd "${pkgname%-*}"
python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 "data/${pkgname%-*}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-*}.desktop"
+ install -Dm644 "data/${pkgname%-*}.svg" "${pkgdir}/usr/share/hicolor/scalable/apps/${pkgname%-*}.svg"
}