summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Wright2022-12-16 08:37:36 +0000
committerJonathan Wright2022-12-16 08:37:36 +0000
commitd1e5e3f95328cbc8ce97a38efba92f866ed4684c (patch)
treec22fc22cbc92df6f0dc0b971263ef1ad60a3eef1
parent9e91afcc9e3680cb96977b9e5388b71f7fbaf279 (diff)
downloadaur-d1e5e3f95328cbc8ce97a38efba92f866ed4684c.tar.gz
Sync Makefile changes
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 3721b908155b..a8e5348c6bdc 100644
--- a/Makefile
+++ b/Makefile
@@ -23,7 +23,7 @@ ifdef ($(string $(pkgrel)),)
use_pkgrel=$(pkgrel)
else
ifeq ($(pkgver),$(current_pkgver))
- use_pkgrel=$(current_pkgrel)+1
+ use_pkgrel=$(shell expr $(current_pkgrel) + 1)
else
use_pkgrel=1
endif
@@ -36,7 +36,7 @@ help: ## Show this help message
.PHONY: clean
clean: ## Clean the current workspace
@echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old package files${CC_END}"
- rm -f *.pkg.tar.{xz,zst} *.zip{,.part}
+ rm -rf *.pkg.tar.{xz,zst} *.{zip,gz,xz,zst}{,.part}
@echo -e "${CC_YELLOW}==>${CC_WHITE} Cleaning up old working directories${CC_END}"
rm -rf ./pkg ./src