summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2024-02-04 21:21:55 +0100
committerFrederik Schwan2024-02-04 21:21:55 +0100
commite0a5c877b81405ea5f5ca2f89247ddff9d9c97dd (patch)
tree85a5db914fc1be84ec05cecd8129cdb6d29a3313
downloadaur-e0a5c877b81405ea5f5ca2f89247ddff9d9c97dd.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84470fce55c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = wayprompt
+ pkgdesc = Multi-purpose prompt tool for Wayland (pinentry)
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://git.sr.ht/~leon_plickat/wayprompt
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = wayland-protocols
+ makedepends = zig
+ depends = fcft
+ depends = libxkbcommon
+ depends = pixman
+ depends = wayland
+ source = git+https://git.sr.ht/~leon_plickat/wayprompt#tag=v0.1.0
+ source = git+https://git.sr.ht/~novakane/zig-fcft
+ source = git+https://github.com/ifreund/zig-pixman.git
+ source = git+https://github.com/ifreund/zig-xkbcommon.git
+ source = git+https://github.com/ifreund/zig-wayland.git
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+
+pkgname = wayprompt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..187090a44ef7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+
+pkgname=wayprompt
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Multi-purpose prompt tool for Wayland (pinentry)'
+url='https://git.sr.ht/~leon_plickat/wayprompt'
+license=(GPL3)
+depends=(fcft libxkbcommon pixman wayland)
+makedepends=(git wayland-protocols zig)
+arch=(x86_64)
+source=(
+ git+https://git.sr.ht/~leon_plickat/wayprompt#tag=v${pkgver}
+ git+https://git.sr.ht/~novakane/zig-fcft
+ git+https://github.com/ifreund/zig-pixman.git
+ git+https://github.com/ifreund/zig-xkbcommon.git
+ git+https://github.com/ifreund/zig-wayland.git
+)
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd ${pkgname}
+ git submodule init
+ git config submodule."deps/zig-wayland".url "${srcdir}/zig-wayland"
+ git config submodule."deps/zig-pixman".url "${srcdir}/zig-pixman"
+ git config submodule."deps/zig-xkbcommon".url "${srcdir}/zig-xkbcommon"
+ git config submodule."deps/zig-fcft".url "${srcdir}/zig-fcft"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd ${pkgname}
+ DESTDIR="build" zig build \
+ --prefix /usr \
+ --search-prefix /usr \
+ -Dtarget=native-linux.5.15-gnu.2.37 \
+ -Dcpu=baseline \
+ -Doptimize=ReleaseSafe \
+ -Dpie=true
+}
+
+package() {
+ cd ${pkgname}
+ mv -v build/* "${pkgdir}"
+}