summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-05-15 02:23:22 -0400
committeréclairevoyant2023-05-15 02:23:22 -0400
commitbf40c735e8d1a4587611568ac413e8b1fdd78435 (patch)
tree365365e88690530561c73d9dae4c07f27ec177ab
downloadaur-bf40c735e8d1a4587611568ac413e8b1fdd78435.tar.gz
wayshot: init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab7ba148d669
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wayshot
+ pkgdesc = Screenshot tool for wlroots compositors
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://git.sr.ht/~shinyzenith/wayshot
+ arch = x86_64
+ license = BSD
+ makedepends = cargo
+ makedepends = git
+ makedepends = scdoc
+ optdepends = slurp: for area selection
+ source = git+https://git.sr.ht/~shinyzenith/wayshot#commit=31baff5229bc8f5bd835b1b7b649513b437dfe5e?signed
+ validpgpkeys = C18E2B48B8DA9B624C8B72D66DD485917B553B7B
+ b2sums = SKIP
+
+pkgname = wayshot
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..713f6f80aff8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..340d81eebf5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: éclairevoyant
+
+pkgname=wayshot
+pkgver=1.2.2
+pkgrel=1
+arch=('x86_64')
+url="https://git.sr.ht/~shinyzenith/$pkgname"
+pkgdesc="Screenshot tool for wlroots compositors"
+license=(BSD)
+optdepends=('slurp: for area selection')
+makedepends=(cargo git scdoc)
+source=("git+$url#commit=31baff5229bc8f5bd835b1b7b649513b437dfe5e?signed")
+b2sums=('SKIP')
+validpgpkeys=('C18E2B48B8DA9B624C8B72D66DD485917B553B7B') # Shinyzenith#6969 (gpgkeypair) <aakashsensharma@gmail.com>
+
+prepare() {
+ cd $pkgname
+
+ # don't waste time zipping manpages
+ rm -rfv build.rs
+
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build(){
+ cd $pkgname
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 target/release/$pkgname -t "$pkgdir/usr/bin/"
+ install -Dm644 docs/$pkgname.1.scd "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm644 docs/$pkgname.7.scd "$pkgdir/usr/share/man/man7/$pkgname.7"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}