summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-05-15 23:18:58 +0200
committerEric Engestrom2020-05-15 23:22:05 +0200
commit0baa70642040c851aa2540ce57cc1828d13396da (patch)
tree4d280ce30e7cfa399e989f7f2e2f01b34ee5a779
parenta846d428c703d7af5f20276292ba0102ddb22372 (diff)
downloadaur-0baa70642040c851aa2540ce57cc1828d13396da.tar.gz
fixup PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5334815a4ba6..9c3aa2dc5b46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = wayvnc-git
- pkgdesc = This is a VNC server for wlroots based Wayland compositors.
- pkgver = r208.9b48290
+ pkgdesc = VNC server for wlroots-based Wayland compositors
+ pkgver = 0.1.2+81.g9b48290d09
pkgrel = 1
url = https://github.com/any1/wayvnc
- arch = i686
arch = x86_64
- license = ISC
- makedepends = meson
+ arch = i686
+ license = custom:ISC
makedepends = git
+ makedepends = meson
makedepends = ninja
+ makedepends = aml-git
+ depends = libglvnd
depends = libxkbcommon
+ depends = libuv
depends = pixman
depends = neatvnc-git
- depends = libglvnd
- depends = gnutls
- source = wayvnc::git+https://github.com/any1/wayvnc.git
+ provides = wayvnc=0.1.2
+ conflicts = wayvnc
+ source = https://github.com/any1/wayvnc
sha512sums = SKIP
pkgname = wayvnc-git
diff --git a/PKGBUILD b/PKGBUILD
index 5424524c00cd..adb5c7253955 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,30 @@
-# Maintainer: Alexander Kempen <alexander dot kempen at posteo dot de>
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+# Maintainer: Andri Yngvason <andri@yngvason.is>
+
pkgname=wayvnc-git
-_pkgname=wayvnc
-pkgver=r208.9b48290
+pkgver=0.1.2+81.g9b48290d09
pkgrel=1
-license=("ISC")
-pkgdesc="This is a VNC server for wlroots based Wayland compositors."
-makedepends=("meson" "git" "ninja")
-depends=("libxkbcommon" "pixman" "neatvnc-git" "libglvnd" "gnutls")
-optdepends=()
-arch=("i686" "x86_64")
-url="https://github.com/any1/wayvnc"
-source=("${_pkgname%-*}::git+https://github.com/any1/wayvnc.git")
+pkgdesc='VNC server for wlroots-based Wayland compositors'
+arch=(x86_64 i686)
+url=https://github.com/any1/wayvnc
+license=(custom:ISC)
+depends=(libglvnd libxkbcommon libuv pixman neatvnc-git)
+makedepends=(git meson ninja aml-git)
+source=("git+$url")
sha512sums=('SKIP')
+conflicts=(wayvnc)
+provides=(wayvnc=${pkgver%+*})
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C wayvnc describe --tags --abbrev=10 | sed 's/^v//; s/-/+/; s/-/./'
}
build() {
- cd "$_pkgname"
- meson \
- --buildtype=release \
- --prefix /usr \
- "$srcdir/build"
- ninja -C "$srcdir/build"
+ arch-meson wayvnc build # --prefix /usr
+ ninja -C build
}
package() {
- cd "$_pkgname"
- DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+ DESTDIR="$pkgdir" ninja -C build install
+ install -Dm 644 wayvnc/COPYING -t "$pkgdir"/usr/share/licenses/$pkgname
}