summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheJackiMonster2021-08-30 13:39:15 +0200
committerTheJackiMonster2021-08-30 13:39:15 +0200
commitbd763c2a46639626f87e0beb129db8fa3a98963c (patch)
tree22be905867fa1715e6bb752101d6d06ba143ca1e
downloadaur-bd763c2a46639626f87e0beb129db8fa3a98963c.tar.gz
Initial commit to build from source
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58c3a515f383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wayward-git
+ pkgdesc = Fast GTK shell and compositor for wayland and weston.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/varmd/wayward
+ arch = any
+ makedepends = wayland
+ makedepends = gcc
+ depends = weston
+ depends = wayland
+ depends = ttf-droid
+ depends = adwaita-icon-theme
+ depends = gtk3
+ depends = sudo
+ provides = wayward
+ options = !emptydirs
+ source = git+https://github.com/varmd/wayward.git
+ sha256sums = SKIP
+
+pkgname = wayward-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32198d86d4d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tobias Frisch <thejackimonster@gmail.com>
+
+pkgname=wayward-git
+_realname=wayward
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Fast GTK shell and compositor for wayland and weston."
+arch=('any')
+url="https://github.com/varmd/wayward"
+depends=('weston' 'wayland' 'ttf-droid' 'adwaita-icon-theme' 'gtk3' 'sudo')
+makedepends=('wayland' 'gcc')
+options=(!emptydirs)
+source=("git+https://github.com/varmd/$_realname.git")
+sha256sums=('SKIP')
+provides=('wayward')
+
+pkgver() {
+ cd "$srcdir/$_realname"
+ git tag | sort -r | head -n1 | cut -c2-
+}
+
+build() {
+ cd "$srcdir/$_realname/source"
+ sh build.sh
+}
+
+package() {
+ cd "$srcdir/$_realname/source"
+ sh install.sh "$pkgdir"
+}