summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Ortega2023-11-20 20:43:19 -0600
committerMartin Ortega2023-11-20 20:43:19 -0600
commitc417eaf3af07603299151047e2509d6c44b053ad (patch)
treef5c21ab232b57c9b853bc287d01958d06256b6bd
downloadaur-c417eaf3af07603299151047e2509d6c44b053ad.tar.gz
First passing build
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
-rw-r--r--wazuh-filebeat.install4
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b66237a2e09d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wazuh-filebeat
+ pkgdesc = Filebeat version for Wazuh
+ pkgver = 7.10.2
+ pkgrel = 1
+ url = https://wazuh.com/
+ install = wazuh-filebeat.install
+ arch = x86_64
+ license = gpl2
+ depends = libcap
+ conflicts = filebeat
+ source = https://packages.wazuh.com/4.x/yum/filebeat-oss-7.10.2-x86_64.rpm
+ validpgpkeys = 9E646BB0630C8FD18ACD15541B93E6A766CD229D
+ sha256sums = 56820530dd749d61ba2750ecefc390393a8a5029dd431bf2eaf6a599a847f8f2
+
+pkgname = wazuh-filebeat
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98da80f91fcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jesus Martin Ortega Martinez (madara125) <martin.ortega.arashi@gmail.com><jortega@condorbs.net>
+# Contribuidor: Kevin Muñoz <kmunoz@condorbs.net>
+pkgname=wazuh-filebeat
+pkgver=7.10.2
+_remRevision=1
+_prodver=${pkgver}-${_remRevision}
+pkgrel=1
+pkgdesc="Filebeat version for Wazuh"
+arch=('x86_64')
+url="https://wazuh.com/"
+license=('gpl2')
+depends=(
+ 'libcap'
+);
+optdepends=(
+);
+conflicts=('filebeat')
+
+validpgpkeys=('9E646BB0630C8FD18ACD15541B93E6A766CD229D')
+
+source=("https://packages.wazuh.com/4.x/yum/filebeat-oss-7.10.2-x86_64.rpm")
+
+sha256sums=('56820530dd749d61ba2750ecefc390393a8a5029dd431bf2eaf6a599a847f8f2')
+
+install=$pkgname.install
+
+package() {
+
+ #Setup
+ cd $pkgdir
+ mv $srcdir/etc .
+ mv $srcdir/lib .
+ mv $srcdir/usr .
+
+ #Set systemd service file perms
+ chmod 644 $pkgdir/lib/systemd/system/filebeat.service
+}
diff --git a/wazuh-filebeat.install b/wazuh-filebeat.install
new file mode 100644
index 000000000000..4c2d6f0cbc20
--- /dev/null
+++ b/wazuh-filebeat.install
@@ -0,0 +1,4 @@
+post_install()
+{
+ echo "Visit https://documentation.wazuh.com/current/installation-guide/wazuh-manager/step-by-step.html and follow the configure instructions for filebeat"
+}