summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Ortega2023-11-17 23:15:53 -0600
committerMartin Ortega2023-11-17 23:15:53 -0600
commit1b7a55508049e2519b8c44d703aeeb49f125c21e (patch)
tree3c4a69aa9c0c1483d16fd994a7e55ec3cb7adb34
parente07de9eeaa724896029c55f3f31aa4566a0c2774 (diff)
downloadaur-1b7a55508049e2519b8c44d703aeeb49f125c21e.tar.gz
adding creation of user and group wazuh-indexer
-rw-r--r--PKGBUILD3
-rw-r--r--PKGBUILD~37
-rw-r--r--wazuh-indexer.install6
3 files changed, 43 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb982d818682..4dba7738c167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,12 +25,11 @@ install=$pkgname.install
package() {
#Setup
- groupadd -f wazuh-indexer
- usuario="wazuh-indexer" && id "$usuario" &>/dev/null || useradd wazuh-indexer -G wazuh-indexer
cd $pkgdir
mv $srcdir/etc .
mv $srcdir/usr .
mv $srcdir/var .
+
#Set systemd service file perms
chmod 644 $pkgdir/usr/lib/systemd/system/wazuh-indexer-performance-analyzer.service
chmod 644 $pkgdir/usr/lib/systemd/system/wazuh-indexer.service
diff --git a/PKGBUILD~ b/PKGBUILD~
new file mode 100644
index 000000000000..fb982d818682
--- /dev/null
+++ b/PKGBUILD~
@@ -0,0 +1,37 @@
+# Maintainer: Jesus Martin Ortega Martinez (madara125) <martin.ortega.arashi@gmail.com><jortega@condorbs.net>
+# Contribuidor: Kevin Muñoz (MrHacker) <kmunoz@condorbs.net><david.munozm@proton.me>
+pkgname=wazuh-indexer
+pkgver=4.6.0
+_remRevision=1
+_prodver=${pkgver}-${_remRevision}
+pkgrel=1
+pkgdesc="Wazuh Indexer for Arch Linux"
+arch=('x86_64')
+url="https://wazuh.com/"
+license=('gpl2')
+depends=(
+ 'coreutils'
+);
+optdepends=(
+);
+validpgpkeys=('9E646BB0630C8FD18ACD15541B93E6A766CD229D')
+
+source=("https://packages.wazuh.com/4.x/yum/${pkgname}-${_prodver}.x86_64.rpm")
+
+sha256sums=('5cb9496f98595c64d351d4b99073c9a7aa48ebe0496eda4853732d2fe66abbf5')
+
+install=$pkgname.install
+
+package() {
+
+ #Setup
+ groupadd -f wazuh-indexer
+ usuario="wazuh-indexer" && id "$usuario" &>/dev/null || useradd wazuh-indexer -G wazuh-indexer
+ cd $pkgdir
+ mv $srcdir/etc .
+ mv $srcdir/usr .
+ mv $srcdir/var .
+ #Set systemd service file perms
+ chmod 644 $pkgdir/usr/lib/systemd/system/wazuh-indexer-performance-analyzer.service
+ chmod 644 $pkgdir/usr/lib/systemd/system/wazuh-indexer.service
+}
diff --git a/wazuh-indexer.install b/wazuh-indexer.install
index c491a2d56847..64127e82eb12 100644
--- a/wazuh-indexer.install
+++ b/wazuh-indexer.install
@@ -1,4 +1,8 @@
post_install()
{
- echo "Visit https://documentation.wazuh.com/current/installation-guide/wazuh-indexer/step-by-step.html and follow the configure instructions"
+ echo "creating wazuh-indexer user and group"
+ groupadd -f wazuh-indexer
+ usuario="wazuh-indexer" && id "$usuario" &>/dev/null || useradd wazuh-indexer -g wazuh-indexer
+ echo "Done!"
+ echo "Visit https://documentation.wazuh.com/current/installation-guide/wazuh-indexer/step-by-step.html and follow the configure instructions and Cluster initialization instructions"
}