summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Ortega2023-11-17 16:41:30 -0600
committerMartin Ortega2023-11-17 16:42:49 -0600
commitc13bfe8b08c254ddc855048193932b5a3fd3f16c (patch)
tree6babe23d5c93047ef349e940d6d9304f3725e0c5
downloadaur-c13bfe8b08c254ddc855048193932b5a3fd3f16c.tar.gz
First passing build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--wazuh-indexer.install4
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7a131c44a7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wazuh-indexer
+ pkgdesc = Wazuh Indexer for Arch Linux
+ pkgver = 4.6.0
+ pkgrel = 1
+ url = https://wazuh.com/
+ install = wazuh-indexer.install
+ arch = x86_64
+ license = gpl2
+ depends = coreutils
+ source = https://packages.wazuh.com/4.x/yum/wazuh-indexer-4.6.0-1.x86_64.rpm
+ validpgpkeys = 9E646BB0630C8FD18ACD15541B93E6A766CD229D
+ sha256sums = 5cb9496f98595c64d351d4b99073c9a7aa48ebe0496eda4853732d2fe66abbf5
+
+pkgname = wazuh-indexer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fec7e197fae1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jesus Martin Ortega Martinez (madara125) <martin.ortega.arashi@gmail.com><jortega@condorbs.net>
+# Contribuidor: Kevin Muñoz <kmunoz@condorbs.net>
+pkgname=wazuh-indexer
+pkgver=4.6.0
+_remRevision=1
+_prodver=${pkgver}-${_remRevision}
+pkgrel=1
+pkgdesc="Wazuh Indexer for Arch Linux"
+arch=('x86_64')
+url="https://wazuh.com/"
+license=('gpl2')
+depends=(
+ 'coreutils'
+);
+optdepends=(
+);
+validpgpkeys=('9E646BB0630C8FD18ACD15541B93E6A766CD229D')
+
+source=("https://packages.wazuh.com/4.x/yum/${pkgname}-${_prodver}.x86_64.rpm")
+
+sha256sums=('5cb9496f98595c64d351d4b99073c9a7aa48ebe0496eda4853732d2fe66abbf5')
+
+install=$pkgname.install
+
+package() {
+
+ #Setup
+ cd $pkgdir
+ mv $srcdir/etc .
+ mv $srcdir/usr .
+ mv $srcdir/var .
+
+ #Set systemd service file perms
+ chmod 644 $pkgdir/usr/lib/systemd/system/wazuh-indexer-performance-analyzer.service
+ chmod 644 $pkgdir/usr/lib/systemd/system/wazuh-indexer.service
+}
diff --git a/wazuh-indexer.install b/wazuh-indexer.install
new file mode 100644
index 000000000000..c491a2d56847
--- /dev/null
+++ b/wazuh-indexer.install
@@ -0,0 +1,4 @@
+post_install()
+{
+ echo "Visit https://documentation.wazuh.com/current/installation-guide/wazuh-indexer/step-by-step.html and follow the configure instructions"
+}