summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Ortega2023-11-17 16:44:30 -0600
committerMartin Ortega2023-11-17 16:44:30 -0600
commit63e1f864c4b4a03954cce3335f5c4b3bdc3047b0 (patch)
tree257391c2bead7f151c0d95068b883b13c844f4e1
downloadaur-63e1f864c4b4a03954cce3335f5c4b3bdc3047b0.tar.gz
First passing build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--wazuh-manager.install4
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc188cc25c52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wazuh-manager
+ pkgdesc = Wazuh Manager for Arch Linux
+ pkgver = 4.6.0
+ pkgrel = 1
+ url = https://wazuh.com/
+ install = wazuh-manager.install
+ arch = x86_64
+ license = gpl2
+ depends = filebeat
+ source = https://packages.wazuh.com/4.x/yum/wazuh-manager-4.6.0-1.x86_64.rpm
+ validpgpkeys = 9E646BB0630C8FD18ACD15541B93E6A766CD229D
+ sha256sums = 335b8970652a03d393866f2105e82c2713673e1f7542dccf25a83a4e3e2233ac
+
+pkgname = wazuh-manager
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a94007e98ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jesus Martin Ortega Martinez (madara125) <martin.ortega.arashi@gmail.com><jortega@condorbs.net>
+# Contribuidor: Kevin Muñoz <kmunoz@condorbs.net>
+pkgname=wazuh-manager
+pkgver=4.6.0
+_remRevision=1
+_prodver=${pkgver}-${_remRevision}
+pkgrel=1
+pkgdesc="Wazuh Manager for Arch Linux"
+arch=('x86_64')
+url="https://wazuh.com/"
+license=('gpl2')
+depends=(
+ 'filebeat'
+);
+optdepends=(
+);
+validpgpkeys=('9E646BB0630C8FD18ACD15541B93E6A766CD229D')
+
+source=("https://packages.wazuh.com/4.x/yum/${pkgname}-${_prodver}.x86_64.rpm")
+
+sha256sums=('335b8970652a03d393866f2105e82c2713673e1f7542dccf25a83a4e3e2233ac')
+
+install=$pkgname.install
+
+package() {
+ #change permissions
+ chmod -R +w "$srcdir/var/ossec"
+ #Setup
+ cd $pkgdir
+ mv $srcdir/etc .
+ mv $srcdir/usr .
+ mv $srcdir/var .
+
+ #Set systemd service file perms
+ chmod 644 $pkgdir/usr/lib/systemd/system/wazuh-manager.service
+}
diff --git a/wazuh-manager.install b/wazuh-manager.install
new file mode 100644
index 000000000000..e6b053dbc2da
--- /dev/null
+++ b/wazuh-manager.install
@@ -0,0 +1,4 @@
+post_install()
+{
+ echo "Visit https://documentation.wazuh.com/current/installation-guide/wazuh-dashboard/step-by-step.html and follow the configure instructions"
+}