summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Perrin2015-07-08 19:04:43 +0200
committerNicolas Perrin2015-07-08 19:04:43 +0200
commita105e1653d51e39ee391b86899a02c3c9ca92177 (patch)
tree5e03f59193b9c22392c9f78960e6539f433d978f
downloadaur-a105e1653d51e39ee391b86899a02c3c9ca92177.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD24
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8480093d3e70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = wazzuf-ripper
+ pkgdesc = Wazzuf Ripper is a software to rip various media as DVD and Blu-ray to .mkv file(s).
+ pkgver = 5.7
+ pkgrel = 1
+ url = http://wazzuf-ripper.lokizone.net/
+ arch = any
+ license = GPL3
+ depends = mplayer
+ depends = mencoder
+ depends = zenity
+ depends = gksu
+ depends = imdb-cli
+ depends = bdchapters
+ depends = mkvtoolnix-cli
+ depends = tsmuxer
+ depends = mediainfo
+ depends = lame
+ depends = vorbis-tools
+ depends = ogmtools
+ depends = p7zip
+ depends = imagemagick
+ depends = libdvdcss
+ depends = lsdvd
+ optdepends = vlc: video dumping support
+ optdepends = cdrkit: genisoimage - DVD to iso file suppport
+ optdepends = opus-tools: Opus audio support
+ source = https://github.com/Booloki/wazzuf-ripper/archive/5.7.tar.gz
+ md5sums = 39d64199157243b982118d3116d22a48
+
+pkgname = wazzuf-ripper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b57b7e29ab4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id$
+# Maintainer : Nicolas Perrin <booloki@lokizone.net>
+
+
+pkgname=wazzuf-ripper
+pkgver=5.7
+pkgrel=1
+pkgdesc="Wazzuf Ripper is a software to rip various media as DVD and Blu-ray to .mkv file(s)."
+arch=(any)
+license=('GPL3')
+url="http://wazzuf-ripper.lokizone.net/"
+depends=('mplayer' 'mencoder' 'zenity' 'gksu' 'imdb-cli' 'bdchapters' 'mkvtoolnix-cli' 'tsmuxer'
+ 'mediainfo' 'lame' 'vorbis-tools' 'ogmtools' 'p7zip' 'imagemagick' 'libdvdcss' 'lsdvd')
+optdepends=('vlc: video dumping support'
+ 'cdrkit: genisoimage - DVD to iso file suppport'
+ 'opus-tools: Opus audio support')
+source=("https://github.com/Booloki/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('39d64199157243b982118d3116d22a48')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}