summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2022-10-11 18:21:19 +0800
committertaotieren2022-10-11 18:21:19 +0800
commit140f378e8acdbf6406089f95d070a69b7225862b (patch)
tree5e6a93fec765e8e63d2a1cc898ca85d0b81afecc
downloadaur-140f378e8acdbf6406089f95d070a69b7225862b.tar.gz
Update 0.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD37
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2ea43ede3f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wchisp
+ pkgdesc = WCH ISP Tool in Rust
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/ch32-rs/wchisp
+ arch = any
+ license = GPL-2.0
+ makedepends = git
+ makedepends = rust
+ depends = cargo
+ provides = wchisp
+ conflicts = wchisp-git
+ options = !strip
+ source = wchisp-0.1.0.tar.gz::https://static.crates.io/crates/wchisp/wchisp-0.1.0.crate
+ sha256sums = c96092aa2bf55deeecfc68e36fb6c224926796a2ced395c0e293f2fe7c0d7a33
+
+pkgname = wchisp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37bb465dc2db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2206f15e35f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=wchisp
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="WCH ISP Tool in Rust"
+arch=('any')
+url="https://github.com/ch32-rs/wchisp"
+license=('GPL-2.0')
+provides=(${pkgname})
+conflicts=(${pkgname}-git)
+replaces=()
+depends=('cargo')
+makedepends=('git' 'rust')
+backup=()
+options=('!strip')
+install=
+source=("${pkgname}-${pkgver}.tar.gz::https://static.crates.io/crates/${pkgname}/${pkgname}-${pkgver}.crate")
+sha256sums=('c96092aa2bf55deeecfc68e36fb6c224926796a2ced395c0e293f2fe7c0d7a33')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --all-features
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --all-features
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ install -Dm0755 -t "${pkgdir}/usr/bin/" "target/release/${pkgname}"
+}