summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author1ridic2024-01-01 18:20:41 +0800
committer1ridic2024-01-01 18:21:23 +0800
commitd36aef44f5a10cfc6dbe0a29219b7df8d1417449 (patch)
tree9c4d3d55a41fc14457dd9df0244fd217465575fd
downloadaur-d36aef44f5a10cfc6dbe0a29219b7df8d1417449.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..485888b6cea9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wcs
+ pkgdesc = "wcs" Stream Meter
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://www.tansi.org/tools/index.html
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc
+ depends = glibc
+ provides = wcs
+ conflicts = wcs
+ source = https://www.tansi.org/tools/wcs.c
+ sha256sums = SKIP
+
+pkgname = wcs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63876fafa1ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: 1ridic <i@iridium.cyou>
+pkgname=wcs
+pkgver=1.2.3
+provides=('wcs')
+conflicts=('wcs')
+license=('GPL2')
+pkgrel=1
+pkgdesc="\"wcs\" Stream Meter"
+arch=(x86_64)
+url="https://www.tansi.org/tools/index.html"
+depends=(glibc)
+makedepends=(gcc)
+source=("https://www.tansi.org/tools/wcs.c")
+sha256sums=('SKIP')
+
+build() {
+ gcc wcs.c -o wcs
+}
+
+package() {
+ install -Dm755 $srcdir/wcs $pkgdir/usr/bin/wcs
+}
+
+