summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMijail Rondón2020-04-07 14:06:41 -0500
committerGitHub2020-04-07 14:06:41 -0500
commit926d91d2effb79d220e082d21c9081aa3453ee72 (patch)
tree75bd967903984afefd3d9d72fb6f548fae29a43a
parentc81cd4c1c73dea4b4fa3d190fd9dd250b1d57226 (diff)
parent6fa70324ae72bda7ba57bc75ad197b8165accf0b (diff)
downloadaur-926d91d2effb79d220e082d21c9081aa3453ee72.tar.gz
Merge pull request #1 from arvl130/convert-filename-case
Convert filename case if supported
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d64fd227c856..cbcf8e410221 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,9 @@ sha256sums=('d310338eaaeae6db3673021c0ec2ec23b9cfb9f9b9d1eb8854d2d60b3a6490f9')
noextract=('pciscsi.exe')
build() {
- lha xi pciscsi.exe pci-scsi.exe
- lha xi pci-scsi.exe nt/wd7296a.sys
+ lha l --convert-filename-case pciscsi.exe 2> /dev/null && local lha_opts="--convert-filename-case"
+ lha xi $lha_opts pciscsi.exe pci-scsi.exe
+ lha xi $lha_opts pci-scsi.exe nt/wd7296a.sys
dd if=wd7296a.sys of=wd719x-risc.bin bs=1 skip=5760 count=14336
dd if=wd7296a.sys of=wd719x-wcs.bin bs=1 skip=20096 count=514
}