summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2021-03-29 12:35:14 +0200
committerStefan Tatschner2021-03-29 12:35:14 +0200
commitc8e0721046bf6fd843e59b7fc4f15575c6304a41 (patch)
tree04e627928c2452ddb4e2a073bc9b9df34564b54a
parent4901cd6ca0707a642d74d1ed09deb77def55bc3f (diff)
downloadaur-c8e0721046bf6fd843e59b7fc4f15575c6304a41.tar.gz
upgpkg: wdisplays 1.0-3
-rw-r--r--.SRCINFO8
-rw-r--r--20.patch48
-rw-r--r--PKGBUILD14
3 files changed, 7 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aa39480f8e0..b3a4e9d8a7c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wdisplays
pkgdesc = GUI display configurator for wlroots compositors
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/cyclopsian/wdisplays
arch = x86_64
license = GPL
@@ -11,10 +11,8 @@ pkgbase = wdisplays
depends = wayland
depends = wayland-protocols
provides = wdisplays
- source = wdisplays-1.0::https://github.com/cyclopsian/wdisplays/archive/1.0.tar.gz
- source = 20.patch
- sha256sums = fa34d5bdfd87d833e18a89b2acacc27833d7297374719773a705f2d3e89cdddf
- sha256sums = e7cc9418945f12632fd17b408fdd8f1c0287f31e4bc3d2afab7683a84e8f2fd2
+ source = wdisplays-1.0::git+https://github.com/artizirk/wdisplays#commit=a9aa7472e37a44b1aaa962d3794f68553e9f81fe
+ sha256sums = SKIP
pkgname = wdisplays
diff --git a/20.patch b/20.patch
deleted file mode 100644
index 10e13b9ee717..000000000000
--- a/20.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 657e2966e556c78f121075c69fe1ba8d2b4dcb73 Mon Sep 17 00:00:00 2001
-From: Simon Ser <contact@emersion.fr>
-Date: Wed, 8 Jul 2020 11:57:35 +0200
-Subject: [PATCH] Use correct versions when binding globals
-
-Changes to protocols aren't forward-compatible. It's not possible to use
-version n+1 when a client has been designed to work with version n. For
-instance in wlr-screencopy v5 a new event has been added. Binding to
-version 5 without upgrading the client leads to libwayland errors
-because libwayland doesn't know how to handle the event.
-
-The client needs to maintain its own version requirements.
-
-Closes: https://github.com/cyclopsian/wdisplays/issues/18
----
- src/outputs.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/outputs.c b/src/outputs.c
-index 9ebf7e5..40410ec 100644
---- a/src/outputs.c
-+++ b/src/outputs.c
-@@ -534,20 +534,20 @@ static void registry_handle_global(void *data, struct wl_registry *registry,
-
- if (strcmp(interface, zwlr_output_manager_v1_interface.name) == 0) {
- state->output_manager = wl_registry_bind(registry, name,
-- &zwlr_output_manager_v1_interface, version);
-+ &zwlr_output_manager_v1_interface, 1);
- zwlr_output_manager_v1_add_listener(state->output_manager,
- &output_manager_listener, state);
- } else if (strcmp(interface, zxdg_output_manager_v1_interface.name) == 0) {
- state->xdg_output_manager = wl_registry_bind(registry, name,
-- &zxdg_output_manager_v1_interface, version);
-+ &zxdg_output_manager_v1_interface, 3);
- } else if(strcmp(interface, zwlr_screencopy_manager_v1_interface.name) == 0) {
- state->copy_manager = wl_registry_bind(registry, name,
-- &zwlr_screencopy_manager_v1_interface, version);
-+ &zwlr_screencopy_manager_v1_interface, 1);
- } else if(strcmp(interface, zwlr_layer_shell_v1_interface.name) == 0) {
- state->layer_shell = wl_registry_bind(registry, name,
-- &zwlr_layer_shell_v1_interface, version);
-+ &zwlr_layer_shell_v1_interface, 1);
- } else if(strcmp(interface, wl_shm_interface.name) == 0) {
-- state->shm = wl_registry_bind(registry, name, &wl_shm_interface, version);
-+ state->shm = wl_registry_bind(registry, name, &wl_shm_interface, 1);
- }
- }
-
diff --git a/PKGBUILD b/PKGBUILD
index 157b99cfb3ca..eaca5bb6c81f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wdisplays
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc='GUI display configurator for wlroots compositors'
url='https://github.com/cyclopsian/wdisplays'
license=('GPL')
@@ -10,15 +10,9 @@ provides=('wdisplays')
arch=('x86_64')
depends=('gtk3' 'libepoxy' 'wayland' 'wayland-protocols')
makedepends=('meson')
-source=("$pkgname-$pkgver::https://github.com/cyclopsian/wdisplays/archive/${pkgver}.tar.gz"
- "20.patch")
-sha256sums=('fa34d5bdfd87d833e18a89b2acacc27833d7297374719773a705f2d3e89cdddf'
- 'e7cc9418945f12632fd17b408fdd8f1c0287f31e4bc3d2afab7683a84e8f2fd2')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/20.patch"
-}
+_commit="a9aa7472e37a44b1aaa962d3794f68553e9f81fe"
+source=("$pkgname-$pkgver::git+https://github.com/artizirk/wdisplays#commit=$_commit")
+sha256sums=('SKIP')
build() {
cd "$pkgname-$pkgver"