summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2019-08-15 22:38:01 +1000
committerStephen Gregoratto2019-08-15 22:38:01 +1000
commit71997a2f5ce55e5176f2abfdecb0da0a7eaa9de8 (patch)
tree91797b1ceda1dd857bcb0dc4e490d058eb50b1bb
downloadaur-71997a2f5ce55e5176f2abfdecb0da0a7eaa9de8.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfba62ee6427
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wdisplays-git
+ pkgdesc = GUI display configurator for wlroots compositors
+ pkgver = r14.ff536e1
+ pkgrel = 1
+ url = https://github.com/cyclopsian/wdisplays
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = libepoxy
+ depends = wayland
+ depends = wayland-protocols
+ provides = wdisplays
+ source = wdisplays::git+https://github.com/cyclopsian/wdisplays
+ sha256sums = SKIP
+
+pkgname = wdisplays-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb9c9290daeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: KingofToasters <dev@sgregoratto.me>
+pkgname=wdisplays-git
+pkgver=r14.ff536e1
+pkgrel=1
+pkgdesc='GUI display configurator for wlroots compositors'
+url='https://github.com/cyclopsian/wdisplays'
+license=('MIT')
+provides=('wdisplays')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('gtk3' 'libepoxy' 'wayland' 'wayland-protocols')
+makedepends=('git' 'meson')
+source=("${pkgname%-git}::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${pkgname%-git}"
+ arch-meson "$srcdir/build"
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+ install -Dm644 "${pkgname%-git}/LICENSE" \
+ "$pkgdir/usr/share/licenses/${pkgname}/LICENCE"
+}