summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdu4rdSHL2021-10-04 21:41:41 -0500
committerEdu4rdSHL2021-10-04 21:41:41 -0500
commit436825eedf846ea01d3b1a48e793fb1995ac9417 (patch)
treee30eea043a2d0a9c8b316315bc74eccc0cc89d5f
parent0b5a18ec2be1d4fa6340cbb07a9fbad9dc80ef46 (diff)
downloadaur-436825eedf846ea01d3b1a48e793fb1995ac9417.tar.gz
Bump package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f9a9655b60f..6b3d350af2b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,18 @@
pkgbase = weakauras-companion-bin
- pkgdesc = A cross-platform application built to provide the missing link between Wago.io and World of Warcraft. (This is a repackage of the official RPM package.)
- pkgver = 3.3.3
+ pkgdesc = A cross-platform application built to provide the missing link between Wago.io and World of Warcraft.
+ pkgver = 3.3.4
pkgrel = 1
url = https://github.com/WeakAuras/WeakAuras-Companion
arch = x86_64
license = GPL2
- depends = electron
- source = https://github.com/WeakAuras/WeakAuras-Companion/releases/download/v3.3.3/weakauras-companion-3.3.3.x86_64.rpm
- sha256sums = d9e61e0bff6b1f91c2d3095a6b0f39df954f7bd8e108ecb38aebd01b717f4a35
+ depends = libxshmfence
+ depends = nss
+ depends = at-spi2-atk
+ depends = atk
+ depends = libdrm
+ depends = gdk-pixbuf2
+ depends = gtk3
+ source = https://github.com/WeakAuras/WeakAuras-Companion/releases/download/v3.3.4/weakauras-companion_3.3.4_amd64.deb
+ sha512sums = ad86a45683a4760ada9709187ad8a8c3302c6580cb4910629d70ad34cc1947aeff611f1e5d19943dc36fc9a5108607752498a6e30dc67ea675df6a63ee1a2beb
pkgname = weakauras-companion-bin
diff --git a/PKGBUILD b/PKGBUILD
index fd6cb3ce9f85..f7208ed41014 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-# Maintainer: Hunter Peavey < printf "dev@die.bots" | sed "s/die.bots/krathalan.net/g" >
+# Maintainer: Eduard Tolosa <edu4rdshl@protonmail.com>
-# General package information
pkgname=weakauras-companion-bin
-pkgver=3.3.3
+pkgver=3.3.4
pkgrel=1
-pkgdesc="A cross-platform application built to provide the missing link between Wago.io and World of Warcraft. (This is a repackage of the official RPM package.)"
-url="https://github.com/WeakAuras/WeakAuras-Companion"
+pkgdesc='A cross-platform application built to provide the missing link between Wago.io and World of Warcraft.'
+url='https://github.com/WeakAuras/WeakAuras-Companion'
license=("GPL2")
arch=("x86_64")
+depends=('libxshmfence' 'nss' 'at-spi2-atk' 'atk' 'libdrm' 'gdk-pixbuf2' 'gtk3')
+source=("https://github.com/WeakAuras/WeakAuras-Companion/releases/download/v$pkgver/weakauras-companion_${pkgver}_amd64.deb")
+sha512sums=('ad86a45683a4760ada9709187ad8a8c3302c6580cb4910629d70ad34cc1947aeff611f1e5d19943dc36fc9a5108607752498a6e30dc67ea675df6a63ee1a2beb')
-source=("${url}/releases/download/v${pkgver}/weakauras-companion-${pkgver}.x86_64.rpm")
-sha256sums=("d9e61e0bff6b1f91c2d3095a6b0f39df954f7bd8e108ecb38aebd01b717f4a35")
-
-depends=("electron")
package() {
- cd "${srcdir}" || exit
- cp -r opt/ usr/ "${pkgdir}"
- chmod 755 "${pkgdir}/opt" "${pkgdir}/usr"
+ install -dm 755 "$pkgdir/usr/bin/"
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
- mkdir -p "${pkgdir}/usr/bin"
- ln -sf "/opt/WeakAuras Companion/weakauras-companion" "${pkgdir}/usr/bin/weakauras-companion"
+ ln -sf "/opt/WeakAuras Companion/weakauras-companion" "${pkgdir}/usr/bin/weakauras-companion"
}
+